intermittent missing and sluggish throttle - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 02-20-2015, 05:29 PM Thread Starter
PSN Newb
 
Join Date: Feb 2015
Posts: 3
intermittent missing and sluggish throttle

New to 6.0 but not to diesels. I have done a pretty good bit of searching but can't seem to find what I am looking for. I have an 04 6.0 stock afaik with approx 260k. It ran fine when I bought it about 4 months ago. Recently it has started intermittently idling rough. The rough idle is accompanied by missing and sluggish throttle. I bought a scan gauge 2 and have been monitoring things. While the problem is occuring Ficm voltage never drops below 46.5. Ebp seems higher. Ect and eot delta gets higher but still within 15 degree limit. Icp doesn't respond instantly to throttle like it normally would.

I haven't gotten a chance to check fuel pressure but both fuel filters have been changed within last 2 months and have maybe 1000 miles on them. Last oil change was about 3k ago done by po. The engine never throws cel.

On a side note when I went to change fuel filters I found a plug disconnected just forward of fuel filter in valley pan. The truck was running fine then and I found nothing for it to plug into so I didn't worry about it.

Any ideas on where to start? I have not monitored ipr or egr while it is happening.
redneckaggie is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 02-21-2015, 02:13 PM
PSN Veteran
 
06-6.0 stoker's Avatar
 
Join Date: May 2011
Location: indianapolis in
Posts: 752
Re: intermittent missing and sluggish throttle

Sounds like maybe the cold is causing stiction and the rough idle and rough running. What's the plug in look like? Trucks probably egr deleted and the valve is gone the plugs just laying there. Not uncommon.

2006 f250 4x4 6in lift 37x13.5 tires
A few engine parts here and there

Back Road Performance tuned
06-6.0 stoker is offline  
post #3 of 4 (permalink) Old 02-21-2015, 04:20 PM Thread Starter
PSN Newb
 
Join Date: Feb 2015
Posts: 3
Re: intermittent missing and sluggish throttle

The plug in is 2 wire side by side I believe it's blue. I will try to snap a picture later. I was told by previous owner that truck was completely stock but not ruling that out. The problem is not limited to when the engine is cold and I live on the coast of Texas. So it hasn't been that cold here. Just pick up Blue Spring upgrade kit. Going to install that later and find a doctor to test fuel pressure. I loaded Xgauges for egr measured and EGR desired into ScanGauge 2. Egr desired reads out but egr measured doesn't. I have double and triple checked coding.
redneckaggie is offline  
 
post #4 of 4 (permalink) Old 02-23-2015, 02:51 PM
Big dumb redneck
 
6speedSD's Avatar
 
Join Date: Apr 2009
Location: Olive Branch, Mississippi
Posts: 4,200
Garage
Re: intermittent missing and sluggish throttle

Look right behind the intake elbow, right up front on top. There is either a round valve (EGR valve) about 3-4" tall, or there is a shiny or colored plate with two bolts in it. If no valve, then your EGR is deleted, and that's what the plug is for. The way you describe it (blue, side by side wiring), sure sounds like the EGR vslve plug to me.

2005 F350 CCLB Dually
Studded, deleted
5" straight piped
155/30's
KC Stage 1.5
Reg return
Beans sump to the stock pump
BPD FICM
Tuned by several...depends on my mood for the day.
6speedSD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome