2005 6.0 Powerstroke Problems - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-04-2015, 04:19 AM Thread Starter
PSN Newb
 
Join Date: Feb 2015
Posts: 1
2005 6.0 Powerstroke Problems

I have a 6.0 2005 F-250 Powerstroke that i've been having some trouble with. About a month ago, I started hearing a loud ticking noise and about a day later, it started pouring white smoke. I ran an injector buzz test thinking it was a bad injector and it came up with injector 8 not firing. So, I went and replaced injector 8, started it up, took it for a ride, and ran a KOER test with the scan tool since it was now running pretty rough. From this test it came up with the code injector 8 low, so I went back in and tested all of the pins in the harness for injector 8 and checked the amperage for the various wires going to the injector and found that all were within spec. I also replaced the connector to the injector since one of the pins had been pushed down too far to make a good connection. After running the KOER test with the scan tool again, this time I got cylinder 8 contribution/balance fault. The only other thing I could think of from here was a bad FICM, so I replaced it, but I'm still getting the cylinder 8 contribution/balance fault code. The truck is running better now though. At low RPM idle it does have a significant knock, but when it goes into high idle, the knock goes away and it runs smoothly. It also runs perfectly fine going down the road. I am truly at a stand still now and have no idea what else to try. Does anyone have an idea of what this could be?
jtalborano is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-04-2015, 07:03 PM
PSN Local
 
Join Date: Jan 2015
Location: NW MS
Posts: 106
Re: 2005 6.0 Powerstroke Problems

Just a though but you may have dropped a lifter. Have you checked your rocker arms?
Saw one where a guy had an awful noise, pulled the cover and he had a bent push rod and a trashed rocker. On the lifter if it was that bad I would assume your low pressure oil pump would be trashed--but maybe it's early. Also--you probably need to do a compression check. Just my thoughts.

2006 F350 4X4 CAB CHASSIS w/ Truck Bed
Blue Spring, Mishimoto tstat
Kdavid1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome