6.0 power loss at wot - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 15 (permalink) Old 04-25-2014, 08:13 AM Thread Starter
PSN Newb
 
Onefast96svt's Avatar
 
Join Date: Mar 2013
Posts: 12
6.0 power loss at wot

I have no issues as in starting or idle. Trucks runs fine at normal stop light to stop light driving or even on the highway. But when I step on the pedal the engine revs and boost is made but it doesn't go anywhere. Speed will slowly climb while still driving fine( no hesitation or missing). Oil pressure is fine but I haven't checked fuel pressure yet. I just change fuel filter yesterday just to see if it would help. What do you guys think?
Onefast96svt is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 04-25-2014, 11:13 AM
PursuitInterceptor
 
HeavyAssault's Avatar
 
Join Date: Jul 2007
Location: Middle, VA
Posts: 3,377
Re: 6.0 power loss at wot

At what RPM are you experiencing the issue?? What is the boost PSI?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


You see, in this world there's two kinds of people my friend....those with loaded guns, and those who dig.

You dig.
HeavyAssault is offline  
post #3 of 15 (permalink) Old 04-25-2014, 11:36 AM Thread Starter
PSN Newb
 
Onefast96svt's Avatar
 
Join Date: Mar 2013
Posts: 12
Re: 6.0 power loss at wot

All RPMs really.from a dead stop , turning at a light doing about 30, and going 60 I floored it each time and it goes but not like I floored it more like I was just half throttling to pass grandma doing 30 on a back road.

From what I have been able to see In the little time I've had , my scan gauge will show up to about 29 or so bug then starts showing -11 -14 and so on. It seems like the engine is Revving up fine and turbo is pushing boost fine but it's just moving. I'm going to check my fuel pressure today and may go buy a fuel pump just in case.

03 Excursion EB 4X4 6.0L Mineral Gray Metallic,20" machined/black Rockstars 33x12.50, 4" lift,Powerstop slotted and drilled rotors,Rancho adjustable shocks,Studs, looney tune wild,CCV MOD, Red Head Steering Box, EGR delete,6.4 banjo,XDP Coolant filter,4" MBPR straight pipe,280amp Alt,Amsoil oil bypass,Go Industries Bull Bar,6000k HIDs,ScanGaugeII
Onefast96svt is offline  
 
post #4 of 15 (permalink) Old 04-25-2014, 11:38 AM
PursuitInterceptor
 
HeavyAssault's Avatar
 
Join Date: Jul 2007
Location: Middle, VA
Posts: 3,377
Re: 6.0 power loss at wot

Sounds more like a VGT side issue on the turbo. Consider the VGT solenoid and perhaps giving the turbine side a complete cleaning.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


You see, in this world there's two kinds of people my friend....those with loaded guns, and those who dig.

You dig.
HeavyAssault is offline  
post #5 of 15 (permalink) Old 04-25-2014, 11:42 AM Thread Starter
PSN Newb
 
Onefast96svt's Avatar
 
Join Date: Mar 2013
Posts: 12
Re: 6.0 power loss at wot

It was just in the shop last week to fix an oil leak from where a "reputable diesel shop" broke a bolt and striped 2 bolts on my turbo. So only 1 was holding it on torquing the top lines of the turbo making them leak. So my new friends which I trust fixed leak, replaced y pipe, did turbo oil line upgrade , and cleaned the turbo while it was out. Now maybe they got the turbo and didn't look at the solenoid. I'll have to call and ask.

03 Excursion EB 4X4 6.0L Mineral Gray Metallic,20" machined/black Rockstars 33x12.50, 4" lift,Powerstop slotted and drilled rotors,Rancho adjustable shocks,Studs, looney tune wild,CCV MOD, Red Head Steering Box, EGR delete,6.4 banjo,XDP Coolant filter,4" MBPR straight pipe,280amp Alt,Amsoil oil bypass,Go Industries Bull Bar,6000k HIDs,ScanGaugeII
Onefast96svt is offline  
post #6 of 15 (permalink) Old 04-25-2014, 11:48 AM
Fixing Broken Stuff
 
toolmangary's Avatar
 
Join Date: Jan 2009
Location: South Lyon Mi
Posts: 2,078
Re: 6.0 power loss at wot

^^, also look and EBP and MAP, make sure the tube is clear going the EPB sensor and the hose from the right side of the intake to the MAP is connected and good. Also what is readings EBP and MAP KOEO and KOER?
Most likely your problem is one of those three items.

2015 Challenger HellCat Redline Red 8sp
1997 F350 4X4 CCLB PSD
2004 Jetta TDI
1999.5 Jetta TDI 11mm pump S7 PP764's 3bar MAP
1986 F350 CC Dually 6.9 ATS turbo lowered
1984 Mark VII 2.4 BMW Turbo Diesel
1970 Roadrunner 383 4sp
1970 Cuda 426 4sp Dana 60
1956 F100
toolmangary is offline  
post #7 of 15 (permalink) Old 04-25-2014, 11:49 AM Thread Starter
PSN Newb
 
Onefast96svt's Avatar
 
Join Date: Mar 2013
Posts: 12
Re: 6.0 power loss at wot

I'll see what the readings are when I get home. May be 4 or so.

03 Excursion EB 4X4 6.0L Mineral Gray Metallic,20" machined/black Rockstars 33x12.50, 4" lift,Powerstop slotted and drilled rotors,Rancho adjustable shocks,Studs, looney tune wild,CCV MOD, Red Head Steering Box, EGR delete,6.4 banjo,XDP Coolant filter,4" MBPR straight pipe,280amp Alt,Amsoil oil bypass,Go Industries Bull Bar,6000k HIDs,ScanGaugeII
Onefast96svt is offline  
post #8 of 15 (permalink) Old 04-25-2014, 12:47 PM Thread Starter
PSN Newb
 
Onefast96svt's Avatar
 
Join Date: Mar 2013
Posts: 12
Re: 6.0 power loss at wot

Quote:
Originally Posted by toolmangary View Post
^^, also look and EBP and MAP, make sure the tube is clear going the EPB sensor and the hose from the right side of the intake to the MAP is connected and good. Also what is readings EBP and MAP KOEO and KOER?
Most likely your problem is one of those three items.
Just to let my ignorance shine and not to google rape my phone, what are the sensors you speak of. I know the map bug the others not sure of. I'm sure once you tell me I'll be like ooh yeah, but sometimes I'm not good with short hand.

And if something was wrong with these sensors wouldn't I get a code ?

03 Excursion EB 4X4 6.0L Mineral Gray Metallic,20" machined/black Rockstars 33x12.50, 4" lift,Powerstop slotted and drilled rotors,Rancho adjustable shocks,Studs, looney tune wild,CCV MOD, Red Head Steering Box, EGR delete,6.4 banjo,XDP Coolant filter,4" MBPR straight pipe,280amp Alt,Amsoil oil bypass,Go Industries Bull Bar,6000k HIDs,ScanGaugeII
Onefast96svt is offline  
post #9 of 15 (permalink) Old 04-25-2014, 01:37 PM
Fixing Broken Stuff
 
toolmangary's Avatar
 
Join Date: Jan 2009
Location: South Lyon Mi
Posts: 2,078
Re: 6.0 power loss at wot

EBP = exhaust back pressure
KOEO = key on engine off
KOER = key on engine run

2015 Challenger HellCat Redline Red 8sp
1997 F350 4X4 CCLB PSD
2004 Jetta TDI
1999.5 Jetta TDI 11mm pump S7 PP764's 3bar MAP
1986 F350 CC Dually 6.9 ATS turbo lowered
1984 Mark VII 2.4 BMW Turbo Diesel
1970 Roadrunner 383 4sp
1970 Cuda 426 4sp Dana 60
1956 F100
toolmangary is offline  
post #10 of 15 (permalink) Old 04-25-2014, 03:30 PM
PSN Local
 
Michipicoten_SuperDuty's Avatar
 
Join Date: Jul 2013
Location: Metamora, MI
Posts: 418
Re: 6.0 power loss at wot

What year truck? What does your injection pressure and duty cycle look like?

2004 F-250 Lariat, 6.0, SCLB, 4wd, Magnaflow turbo-back, EGR delete, studded, 6.4 banjo, new oil cooler and HPOP as of 5-11-2014
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Michipicoten_SuperDuty is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome