the unsolvable problem - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 20 (permalink) Old 04-19-2014, 12:40 AM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
the unsolvable problem

Got an 06f250 been to 4 different shops and still no answers. 2 dealers and 2 powerstroke only specialty shops. Truck ran great decided to do headstuds egr delete and powermax turbo. After install the truck has never ran right and has the exact same symptoms without change or improvement fo about 1000miles now. Truck starts fine cold or warm regardless of outside temp. Truck has very little throttle responce slow turbo spool low boost and lots of lag. Injector are loud and has a minor miss. Fuel pressure never drops below 57psi icp is very strong and a little high at idle 770ish. Ipr duty cycle good check turbo every way possible. Its working good. Checked all boots and connectors uppipes.. you name it i probably checked it 10 times. No codes injectors check out good. I do have high ebp though on the big end. Reading in the mid to high 50s at 20psi of boost. It even revs slow in park. No smoke. Almost seems like injector timing is off. Had custom sct tuness written for pm. They helped but on street tune its stillmuch slower then a stock truck at any rpm. Lots of low end smoke with the tunes. None on top. Everything that can be tested with ids checks out... help me figure this out and i will mail you 200$. Lol... im at my wits end
truckguy876 is offline  
Sponsored Links
Advertisement
 
post #2 of 20 (permalink) Old 04-19-2014, 01:00 AM
Administrator
 
Zmann's Avatar
 
Join Date: Nov 2010
Posts: 32,929
Re: the unsolvable problem

I would be tempted to put the old turbo back on
only because if it true that this problem occurred with the addition of a turbo and head studs

I would want to isolate the problem

,
,
,
,
DTR's Donation page

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

RIP DTR Ron
you are missed and will live on through your great video library contribution to the DIY community

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Zmann is offline  
post #3 of 20 (permalink) Old 04-19-2014, 01:19 AM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
Re: the unsolvable problem

I no longer have it
truckguy876 is offline  
 
post #4 of 20 (permalink) Old 04-20-2014, 05:34 AM
PSN Veteran
 
Join Date: Dec 2010
Posts: 2,086
Re: the unsolvable problem

I would install the original tune, as the power max should work fine. On your EGR delete, is your valve still in place? What delete kit was used? You should be able to get some result from a cylinder contribution test and run KOEO and KOER tests. A common problem I see after stud jobs are people do not tighten injectors down right and will develop a miss. Usually it is from not cleaning the oil from the hold down bolt holes. Last is to double check all injector and FICM connections.
lenzhotrod is offline  
post #5 of 20 (permalink) Old 04-20-2014, 08:09 PM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
Re: the unsolvable problem

Been running on stock tune. The truck runs pretty smooth just has no power. Tried with valve plugged in and unplugged. On stock tune exhaust doesnt have the rasp it use to. Its straight piped. Its an rcd delete. When injectors were installed i blew the oil out of the bolt hole using compressed air and torqued to spec. Checked ficm connectors a thousand times and checked pins on ficm too contribution and balance test checked out and all koeo and koer tests look good. Passed bubble test. Idk... does have icp on the high side and high ebp wile accerating.
truckguy876 is offline  
post #6 of 20 (permalink) Old 04-20-2014, 08:23 PM
Six Point Slow
 
justinstorm77's Avatar
 
Join Date: Feb 2014
Location: wallingford, ct
Posts: 83
Re: the unsolvable problem

Had one of these same scenarios at the shop a few weeks back, it ended up being an injector failure that the ECM could not pick up. We used a cylinder performance analyzer to find the issue. Problem is the truck came back a few days ago for the same issue. Hav e not gotten back to it yet as we are pretty slammed with work. I'll let you know what we find.
justinstorm77 is offline  
post #7 of 20 (permalink) Old 04-20-2014, 08:44 PM
whistle tits
 
ghohouston's Avatar
 
Join Date: Mar 2011
Location: Lewisville, Texas
Posts: 3,498
Re: the unsolvable problem

Checked map sensor line, and made sure the nipple is clear all through the intake?


1997 F350 SRW CCLB 7.3 ZF5 4x4
ghohouston is offline  
post #8 of 20 (permalink) Old 04-20-2014, 09:53 PM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
Re: the unsolvable problem

Map tube and nipple good.. not clogged no holes
truckguy876 is offline  
post #9 of 20 (permalink) Old 04-20-2014, 09:59 PM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
Re: the unsolvable problem

With stock tune it runs smooth with no smoke at any rpm. Revs slow when in park and is overall extreamly slow. Like slower than 6.9 idi. The injectors are really loud. More so on passengers side. Low boost. Tons of lag. No codes.
truckguy876 is offline  
post #10 of 20 (permalink) Old 04-20-2014, 10:02 PM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
Re: the unsolvable problem

Wont even spin the tires in the dirt.
truckguy876 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome