No start, security light blinking - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 21 (permalink) Old 03-28-2014, 11:45 PM Thread Starter
PSN Newb
 
Join Date: Mar 2014
Posts: 9
No start, security light blinking

Hi folks,

Recently got myself a 2005 f350 SD 6.0 PSD which has been running great except for today after I got it all loaded up for a run to the dump. Got in, turned the key to the run (glow plug) position and the lights on the dash didn't illuminate. Turned it to the off position, back to run and again no lights on the dash, everything else, radio, climate control all work though. Battery is not dead lol, all lights and everything work as they should. Then I noticed that the red light on the left side of the dash (alarm??) kept blinking about once a second whether i had the key in the ignition in the off, or run position, or even if the key isn't in the ignition. So it seems that for what every reason the little black fob thing isn't talking with the immobilizer, or what ever it is... sorry about my vagueness, not really sure about what the actual names are. Does anyone have any ideas what this could be? Truck is dead in the water right now and I need it to move.

Any and all help appreciated.
Cheers Guys
Gary
superflygary is offline  
Sponsored Links
Advertisement
 
post #2 of 21 (permalink) Old 03-29-2014, 12:39 AM
PSN Local
 
jammin60's Avatar
 
Join Date: Apr 2011
Posts: 269
Re: No start, security light blinking

Have you tried getting out locking the doors, set the panic off then stop then stop the panic then unlock?

2006 CCSB 4x4 ARP studs, FCDP egr delete and coolant filter, SCT tuned by Innovative, 6.4 banjos, MBRP 4" Turbo back, Edge Insight CTS, Blue Spring Kit, 160amp alt with remote rectifier from Quick Start, Icon 2.5", toyo mt's

Made for work by Ford, Made for fun by FCDP

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
So how is that Hope and Change workin out for ya?
jammin60 is offline  
post #3 of 21 (permalink) Old 03-29-2014, 12:46 AM Thread Starter
PSN Newb
 
Join Date: Mar 2014
Posts: 9
Re: No start, security light blinking

I have now and no change.

A little more info as I've been doing some investigating. I don't have one of those keys with the chip in it as far as I can see, i.e. no square access hole. My chip thing is a separate black dongle on my key chain. Does this indicate that it's an aftermarket immobilizer I have or did the 2005 come with one that style?

Really stuck here... no idea what to do
superflygary is offline  
 
post #4 of 21 (permalink) Old 03-29-2014, 01:30 AM
PSN Veteran
 
2Dstorm's Avatar
 
Join Date: Jan 2014
Location: Murphy, TX
Posts: 1,069
Re: No start, security light blinking

Call me I'll tell you how to start it 469-774-9706 Eric

Pmax & batmowheel
Banks technicooler
Arp's
Warren 175/75's
Fass titanium 125 w/ sump
Volant intake
5" mrbp turbo back 6" tip
Reg. return w/6.4 banjos and oil and coolant filter
Sct itsx on iPad w/ Drew's tunes
Idp ficm tune
Snow water/meth
Empty bank account
2Dstorm is offline  
post #5 of 21 (permalink) Old 03-29-2014, 02:45 AM Thread Starter
PSN Newb
 
Join Date: Mar 2014
Posts: 9
Re: No start, security light blinking

Thanks for the offer Eric, a little late now here to be getting involved in it, but I'll give a call tomorrow if no one else has any ideas. Can you whet my appetite by sharing what you think the problem may be?

Thanks again, very generous of you.
superflygary is offline  
post #6 of 21 (permalink) Old 03-29-2014, 03:56 AM
Big dumb redneck
 
6speedSD's Avatar
 
Join Date: Apr 2009
Location: Olive Branch, Mississippi
Posts: 4,200
Garage
Re: No start, security light blinking

I'm curious myself....

2005 F350 CCLB Dually
Studded, deleted
5" straight piped
155/30's
KC Stage 1.5
Reg return
Beans sump to the stock pump
BPD FICM
Tuned by several...depends on my mood for the day.
6speedSD is offline  
post #7 of 21 (permalink) Old 03-29-2014, 04:33 AM
PSN Veteran
 
2Dstorm's Avatar
 
Join Date: Jan 2014
Location: Murphy, TX
Posts: 1,069
Re: No start, security light blinking

Do you have a tuner?
Aftermarket radio?
First place to start would be checking fuses especially the block fuses under the dash. I have had a similar problem before. Hitting bumps off road cause my radio to ground out which popped one of the block fuses under the dash. Not saying this is the problem but you never know on these things.

To start the truck if security is locked out you just have to bypass the system it's fairly easy.

1) turn key to on position
2) under the hood on passenger side fender up high there is a fuse link
3) locate and disconnect the link drag the wire over to your positive battery cable
4) touch wire to positive terminal truck will turn over

This puts direct power to the starter and bypasses the anti-theft system. If the truck will not start you have a fuse bad the block fuses need to be pulled out and checked they are hard to see.

Pmax & batmowheel
Banks technicooler
Arp's
Warren 175/75's
Fass titanium 125 w/ sump
Volant intake
5" mrbp turbo back 6" tip
Reg. return w/6.4 banjos and oil and coolant filter
Sct itsx on iPad w/ Drew's tunes
Idp ficm tune
Snow water/meth
Empty bank account
2Dstorm is offline  
post #8 of 21 (permalink) Old 03-29-2014, 04:25 PM Thread Starter
PSN Newb
 
Join Date: Mar 2014
Posts: 9
Re: No start, security light blinking

Nope no tuner, stock radio. I checked all the fuses which had, starter, cluster, ignition in their description and they were all good, but I'll check those block ones... you mean the big square ones right? Same place under the steering wheel?

I guess the bypass is just to see if I have a bad fuse, as its still pretty cold here and I imagine ill have a hard time starting it without the glow plugs being able to cycle. I'll report back with any findings, otherwise I think I'm going to have to tow it to the "cringe" dealer unless anyone has any other ideas. i was hoping to hear that I just had to find the immobilizer and check some wires or something, but I can't find where it is or how to access it, or anything.
superflygary is offline  
post #9 of 21 (permalink) Old 03-29-2014, 09:48 PM Thread Starter
PSN Newb
 
Join Date: Mar 2014
Posts: 9
Re: No start, security light blinking

So it seems the 2005 f-350 are the only truck which don't have a factory immobilizer, so it's an after market one which has crapped out on me... I went to the dealership and asked about it.

Sooo, it looks like I have to figure out how to locate and remove one of those now.

Just wanted to report back on the progress.
superflygary is offline  
post #10 of 21 (permalink) Old 03-30-2014, 12:31 AM
Administrator
 
Zmann's Avatar
 
Join Date: Nov 2010
Posts: 32,929
Re: No start, security light blinking

thanks
my 06 F 250 King Ranch does not have Pats or an OEM security either

no properly installed aftermarket Alarm should keep your dash cluster from illuminating with the key on

Quote:
turned the key to the run (glow plug) position and the lights on the dash didn't illuminate. Turned it to the off position, back to run and again no lights on the dash, everything else, radio, climate control all work though. Battery is not dead lol, all lights and everything work as they should.

,
,
,
,
DTR's Donation page

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

RIP DTR Ron
you are missed and will live on through your great video library contribution to the DIY community

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Zmann is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome