Losing Power.. - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 03-28-2014, 03:05 AM Thread Starter
PSN Local
 
Join Date: Mar 2013
Location: Southwest, MI
Posts: 88
Losing Power..

Ok so this is going to be kind of long but I have a 2004 6.0 and last spring I was having problems with my EGR so I decided to do an EGR delete kit. I don't remember what brand the kit was but I also replaced the oil cooler. My mechanic told me to buy a Doorman oil cooler. I bought the oil cooler he installed it.. Everything ran well until about January. All the sudden I went to pass a car one day and it would kinda like bog, it had no power, being winter time I didn't get on it real hard very often so I don't know how long it was like that for, you could only tell when you got on it otherwise the truck ran normal. So I took it back to my mechanic and he found out that the gasket around the oil cooler had disintegrated and actually clogged up a screen in the oil cooler or HPOP (I don't remember exactly what he said) but anyway he had called Doorman and told them what happened and sent in pictures and it said that it was a defective gasket and they had a recall on them so they sent me my money back and we bought a gasket from Ford so we wouldn't have this problem again. Well everything ran good again until Tuesday---------------------

Tuesday when I was driving home from work I went to pass someone and it lost power again was kinda boggy when I would get on it (it would run ok when I was easy on it) so it would pretty much act the same way it did in January. The RPMs would not go over 2500 when I went to pass them so I was starting to think it was the same thing as before but when I went to take my truck to my mechanic today I drove it there and it ran fine. It had all power and was not bogging. There was no smoke, I have no idea what the problem is. Its obviously not the same thing since it is ok now. Does anyone have any idea what is starting to go bad? Something is, I just have to figure out what...

2004 F-250 Crew Cab Short Bed, Lariat, 6 Inch Suspension Lift, 315/75/16 Coopers, Moto Metal 951 Wheels, Black Billet Grill, Smoked Halo HID's, Smoked Recon Mirror Turn Signals, LED Cab Lights, LED 3rd Brake Lights, Black 08 Super Duty Rear Bumper, 5 Inch Turbo Back Exhaust
jmbannow is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 03-28-2014, 04:51 AM
Big dumb redneck
 
6speedSD's Avatar
 
Join Date: Apr 2009
Location: Olive Branch, Mississippi
Posts: 4,200
Garage
Re: Losing Power..

First off stay away from Dorman coolers. I think you can attest to that! Use OEM every time.

Get the codes scanned. See what's stored on there. That's the first step.

2005 F350 CCLB Dually
Studded, deleted
5" straight piped
155/30's
KC Stage 1.5
Reg return
Beans sump to the stock pump
BPD FICM
Tuned by several...depends on my mood for the day.
6speedSD is offline  
post #3 of 6 (permalink) Old 03-28-2014, 06:10 AM Thread Starter
PSN Local
 
Join Date: Mar 2013
Location: Southwest, MI
Posts: 88
Re: Losing Power..

Yea I learned spend the money and buy from ford. A buddy at work has a code reader and when we hooked it up it showed no codes.. I thought that was kind of weird but we checked it twice and nothing. And when it happened I had no lights pop up on the dash and all my gauges were normal.. My mechanic said he's going to hook it up to the computer this weekend but he's stumped he said this is a new problem to him.

2004 F-250 Crew Cab Short Bed, Lariat, 6 Inch Suspension Lift, 315/75/16 Coopers, Moto Metal 951 Wheels, Black Billet Grill, Smoked Halo HID's, Smoked Recon Mirror Turn Signals, LED Cab Lights, LED 3rd Brake Lights, Black 08 Super Duty Rear Bumper, 5 Inch Turbo Back Exhaust
jmbannow is offline  
 
post #4 of 6 (permalink) Old 03-28-2014, 07:13 AM
2002 7.3L
 
Ryanisme23's Avatar
 
Join Date: Feb 2014
Location: Texas
Posts: 14
Re: Losing Power..

If it is starting to stumble when you increase pressure on the gas peddle, you may want to begin looking at possible fuel delivery issues. first, try replacing the fuel filter if you haven't done so yet. just curious as to what your fuel level was at on the gauge when it started bogging down? I know for a fact that there are issues known to develop at a quarter tank with the 7.3's.

02 7.3L LARIAT
K&N COLD AIR INTAKE
4" EXHAUST WITH 5" CROME TIP
EDGE PROGRAMMER
4" LIFT WITH 35" NITTO TG's
OPEN COUNTRY BULL BAR
6" KC LIGHTS BAR MOUNTED
Ryanisme23 is offline  
post #5 of 6 (permalink) Old 03-28-2014, 12:27 PM Thread Starter
PSN Local
 
Join Date: Mar 2013
Location: Southwest, MI
Posts: 88
Re: Losing Power..

My fuel gauge said about halfway between quarter and half tank. The weirdest thing though is that it wasn't messing up yesterday.

2004 F-250 Crew Cab Short Bed, Lariat, 6 Inch Suspension Lift, 315/75/16 Coopers, Moto Metal 951 Wheels, Black Billet Grill, Smoked Halo HID's, Smoked Recon Mirror Turn Signals, LED Cab Lights, LED 3rd Brake Lights, Black 08 Super Duty Rear Bumper, 5 Inch Turbo Back Exhaust
jmbannow is offline  
post #6 of 6 (permalink) Old 03-28-2014, 04:10 PM
Big dumb redneck
 
6speedSD's Avatar
 
Join Date: Apr 2009
Location: Olive Branch, Mississippi
Posts: 4,200
Garage
Re: Losing Power..

Generic code readers won't read the hard codes. You'll need something like AE, IDS, etc.

2005 F350 CCLB Dually
Studded, deleted
5" straight piped
155/30's
KC Stage 1.5
Reg return
Beans sump to the stock pump
BPD FICM
Tuned by several...depends on my mood for the day.
6speedSD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome