zero power after hg - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 40 (permalink) Old 03-13-2014, 03:52 PM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
zero power after hg

Truck starts good idles good but has no power. Wont power brake over 1000rpm. No codes. Did hg egr delete studs powermax and afe intake. Has 60psi of fuel pressure. Is full of oil. Ficm has propper voltage. When i take it down the road it will eventually get going and build boost but doesnt have the powerit should. Checked all intercooler boots unplugged icp checked ebp please help
truckguy876 is offline  
Sponsored Links
Advertisement
 
post #2 of 40 (permalink) Old 03-13-2014, 03:53 PM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
Re: zero power after hg

Also no smoke
truckguy876 is offline  
post #3 of 40 (permalink) Old 03-13-2014, 07:08 PM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
Re: zero power after hg

truckguy876 is offline  
 
post #4 of 40 (permalink) Old 03-13-2014, 07:18 PM
PSN Local
 
jfarmer86's Avatar
 
Join Date: Aug 2012
Posts: 301
Re: zero power after hg

Did you have tunes on it before you tore it down?
jfarmer86 is offline  
post #5 of 40 (permalink) Old 03-13-2014, 07:21 PM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
Re: zero power after hg

No tunes before or after. Truck ran great before tear down
truckguy876 is offline  
post #6 of 40 (permalink) Old 03-13-2014, 07:25 PM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
Re: zero power after hg

Also it even revs slow while in park.
truckguy876 is offline  
post #7 of 40 (permalink) Old 03-13-2014, 07:26 PM
PSN Local
 
jfarmer86's Avatar
 
Join Date: Aug 2012
Posts: 301
Re: zero power after hg

Check all connectors? MAP EBP especially?
jfarmer86 is offline  
post #8 of 40 (permalink) Old 03-13-2014, 07:29 PM Thread Starter
super pro
 
Join Date: Mar 2012
Posts: 65
Re: zero power after hg

Checked and triple checked. Checked map readings koeo and it was reading right.
truckguy876 is offline  
post #9 of 40 (permalink) Old 03-13-2014, 07:31 PM
PSN Local
 
03fathead6.0's Avatar
 
Join Date: Apr 2012
Location: North Canton, Ohio
Posts: 271
Re: zero power after hg

fuel pressure regulator perhaps?

2003 F250 6.0, 4" on Pro Comp 35's, Twin Grand rock 6" mitre cuts set to 2" above cab, Dyno Mat cab, SCT X4, Blue spring, CCV mod, Delta tool box. And it is NEVER CLEAN

I dont walk this way because of the wounds I have suffered in the line of duty, but because my balls are just that big!
03fathead6.0 is offline  
post #10 of 40 (permalink) Old 03-13-2014, 07:32 PM
PSN Local
 
jfarmer86's Avatar
 
Join Date: Aug 2012
Posts: 301
Re: zero power after hg

Have you tried resetting the KAM? Turbo solenoid plugged in all the way? No codes? Sorry just going threw my mind process =) How far did you drive it after? Did you prime the fuel system to see if it had any air?
jfarmer86 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome