Need some ideas - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 03-12-2014, 05:54 PM Thread Starter
PSN Newb
 
Join Date: Jan 2013
Posts: 6
Need some ideas

Hey guys, I have been a long time lurker and don't think I have ever posted. I need some help with my 2005 6.0. I have searched and read a ton, I can't seam to track down my issue. First off the truck has an egr delete and the updated STC fitting with the stand pipes and dumby plugs. I also just installed a new injector in #2 because of a contribution code. Just cleaned the turbo when I did the STC fitting. Also did the blue spring and 6.4 banjo bolts. I am running a SCT live wire programmer with 4 inch exhaust. No custom tunes

The current issue is, when I try to get into the throttle at all it bucks and acts like it's not getting fuel, I changed that injector and the truck does idle better now and at cruise seams to be smoother, but it didn't fix the bucking. It does take off like crazy now with the new injector for a second and then starts to buck again. If I am super smooth with the throttle I can get up to highway speeds,and it runs smooth down the highway, but if I get into the throttle just a little to hard it bucks and hiccups

I have check FICIM voltage and also the ICP Pressures. Both checkout good and I have also watched the scanner on the cylinder contribution codes and when it bucks it doesn't show any cylinders missing. I have also pulled the programmer and it still does the same thing just not as bad. I also just changed the fuel filters and oil not even 3,000 miles ago. My next step is to check fuel pressure at the bowl and pull the frame filter out and see what it looks like.

Thanks guys any help or ideas would be great
Bones96 is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 03-12-2014, 06:05 PM
PSN Local
 
Wheelhop's Avatar
 
Join Date: Jul 2012
Posts: 218
Re: Need some ideas

It might be worth a try to clean the tube going to your EBP sensor. If it gets sooted up, it'll cause some issues like that.
Wheelhop is offline  
post #3 of 13 (permalink) Old 03-12-2014, 06:07 PM
PSN Veteran
 
2Dstorm's Avatar
 
Join Date: Jan 2014
Location: Murphy, TX
Posts: 1,069
Re: Need some ideas

It's another injector get a scan guage the sct tuners don't always pickup injector codes

Pmax & batmowheel
Banks technicooler
Arp's
Warren 175/75's
Fass titanium 125 w/ sump
Volant intake
5" mrbp turbo back 6" tip
Reg. return w/6.4 banjos and oil and coolant filter
Sct itsx on iPad w/ Drew's tunes
Idp ficm tune
Snow water/meth
Empty bank account
2Dstorm is offline  
 
post #4 of 13 (permalink) Old 03-12-2014, 06:17 PM
Fixing Broken Stuff
 
toolmangary's Avatar
 
Join Date: Jan 2009
Location: South Lyon Mi
Posts: 2,078
Re: Need some ideas

or the one you put in. Who's injector did you use?

2015 Challenger HellCat Redline Red 8sp
1997 F350 4X4 CCLB PSD
2004 Jetta TDI
1999.5 Jetta TDI 11mm pump S7 PP764's 3bar MAP
1986 F350 CC Dually 6.9 ATS turbo lowered
1984 Mark VII 2.4 BMW Turbo Diesel
1970 Roadrunner 383 4sp
1970 Cuda 426 4sp Dana 60
1956 F100
toolmangary is offline  
post #5 of 13 (permalink) Old 03-12-2014, 07:49 PM
PSN Veteran
 
2Dstorm's Avatar
 
Join Date: Jan 2014
Location: Murphy, TX
Posts: 1,069
Re: Need some ideas

Did you pull the rubber cap off the injector? Just saying I've done it lol

Pmax & batmowheel
Banks technicooler
Arp's
Warren 175/75's
Fass titanium 125 w/ sump
Volant intake
5" mrbp turbo back 6" tip
Reg. return w/6.4 banjos and oil and coolant filter
Sct itsx on iPad w/ Drew's tunes
Idp ficm tune
Snow water/meth
Empty bank account
2Dstorm is offline  
post #6 of 13 (permalink) Old 03-12-2014, 10:37 PM Thread Starter
PSN Newb
 
Join Date: Jan 2013
Posts: 6
Re: Need some ideas

Forgot to mention I cleaned the EBP sensor already and I have been using a snap~on solus scanner and that doesn't show up with more injectors. I did remove the rubber cap.
Bones96 is offline  
post #7 of 13 (permalink) Old 03-12-2014, 10:38 PM Thread Starter
PSN Newb
 
Join Date: Jan 2013
Posts: 6
Re: Need some ideas

Oh and its was a reman injector right from Ford.
Bones96 is offline  
post #8 of 13 (permalink) Old 03-13-2014, 01:15 AM
PSN Veteran
 
Join Date: Dec 2010
Posts: 2,086
Re: Need some ideas

Bucking can also be from sticking turbo vanes.
lenzhotrod is offline  
post #9 of 13 (permalink) Old 03-13-2014, 02:16 AM
PSN Veteran
 
2Dstorm's Avatar
 
Join Date: Jan 2014
Location: Murphy, TX
Posts: 1,069
Re: Need some ideas

Check this hose for leaks, it will cause your turbo vanes to shutter
Attached Images
File Type: jpg image.jpg (16.1 KB, 14 views)

Pmax & batmowheel
Banks technicooler
Arp's
Warren 175/75's
Fass titanium 125 w/ sump
Volant intake
5" mrbp turbo back 6" tip
Reg. return w/6.4 banjos and oil and coolant filter
Sct itsx on iPad w/ Drew's tunes
Idp ficm tune
Snow water/meth
Empty bank account
2Dstorm is offline  
post #10 of 13 (permalink) Old 03-13-2014, 01:15 PM Thread Starter
PSN Newb
 
Join Date: Jan 2013
Posts: 6
Re: Need some ideas

Map sensor hose checked out good, I removed the tune again this morning and it doesn't buck or seem to miss. I think I am going to barrow a friends tuner and see if it does it with his tuner in the truck. Got my extra fuel cap in yesterday also so I can make a setup to check fuel pressure.
Bones96 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome