6.0 rough start then tryed to dye - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-12-2014, 12:46 AM Thread Starter
PSN Local
 
Join Date: Dec 2013
Posts: 102
6.0 rough start then tryed to dye

So I have a few problems that just started up recently.
So had just replaced the ficm a week ago. And it ran great now it is acting up back. First problem is the turbo doesn't want to build over 5 psi of boost some time it works fine. Checked the boots and other connections. Will check ebp tube and sensor.

Next is that I went to start the truck and I started real rough black and then some grey smoke. Then let it warm up for a few minuets EOT was around 100 degrees. Then I put it in drive and it felt like it died but I was just barely running. So I put it in park and the Rpm's came up and let it run while then shut it down for fear that something is very wrong. Also when the truck was running it had a very rythmic surge.

Any ideas where to look first before I pull this dang thing to a shop.

Truck info
2004 f250
Fuel filters 1000 miles ago
Oil filter 1000 miles ago
Fresh oil 1000 miles ago (rotella T6)
Also ficm voltage since being replaced never has dropped under 47.5
And logic at 13.5

Planing on doing an egr delete and blue spring this weekend but this happend
So want to get it all fixed up hopefully

Sorry I just wrote a story

Thanks
Tj561CO is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome