FICM Logic Power - PowerStrokeNation : Ford Powerstroke Diesel Forum


Home Today's Posts Mark Forums Read
Go Back   PowerStrokeNation : Ford Powerstroke Diesel Forum > Super Duty 1999-Current > 6.0L Power Stroke Technical Info
Register Members List Timeslips Calendar Auto Loans Sponsors Becoming a Sponsor Mark Forums Read Auto Escrow

PowerStrokeNation.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 10-28-2012, 05:45 AM
asatriano
Offline
PSN Newb
Member's Gallery
 
Join Date: Sep 2012
Posts: 16
FICM Logic Power

Alright looking for some guidance from the old pro's around here on this one.

Truck is a sucker for cold start in CO where it's chilly.

163xxx miles on this thing

Replaced injectors that were failing.
Monitoring cumulative misfires on others via scan gauge. nothing showing weird.

FPR Replaced, GPCM replaced.

EOT ECT within delta.

ICP IPR within range with EOT @190 or so.

5w40 running through system.

Pulled EGR Valve and cleaned it... didn't lube great going back in and had terrible black smoke on acceleration from stop... thought i broke an injector tip, read data from scan gauge, decided to pull again. Oring ripped going in and shard was stuck in the bottom of the housing on the valve.

New Oring kit, 5w40 to grease it in, no black smoke... ever. well, unless it's up over 3,000 rpm's for a second it'll puff black.

Drained fuel water seperator.
Changed FPR because of low pressure.

Cold start still an issue.

My FVP never drops below 47.5 KOEO and at cranking
FMP at 12ish KOEO and cranking
FLP at 12ish KOEO

....FLP sits at 9 while cranking.

Before condemning the FICM and pulling it ive read that this is the reading it's getting from batteries/alt.

My batt's are good, load tested, and per the scangauge my alt is reading good in charging as soon as those glow plugs kick off at start up.

Is that FICM Logic Power enough to cause a no start?
Once started the delta between batt voltage and FLP will be greater than 2, and the FICM Main Power is in line with that?

Before yanking FICM off and sending it in does that sound like it's bad, or due to the fact that main power and logic power are off could it be something like delivery of batt voltage? if that was the case would the FICM Voltage Power show similar results in underperformance from battery deliver? as of now it isn't.Seems like it's having no issue converting 12v to 48v for the FICM Voltage Power, but the other two are straggling...

Both FMP and FLP come up after running for a few (plugs cycling off i assume) but for the period of 5-10 minutes they're way low.

Help me before i yank it off, ship it halfway across the country, and put it on to be frustrated that it didn't work...

Thanks,
TJ
Reply With Quote Go to the top
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
  #2  
Old 10-28-2012, 12:01 PM
Mhatlen's Avatar
Mhatlen
Offline
Fuel it up again Dummy
Member's Gallery
 
Join Date: Jun 2012
Location: Elk Grove,Ca
Posts: 1,002
Send a message via MSN to Mhatlen
Re: FICM Logic Power

9 volts is probably your batteries, how old are they? Should be 10.5-11v cranking......
How do the cables look?
What is the voltage after it starts?
After 2 mins when alt comes on, what voltage do you have.

Have you tested the amperage draw for each bank on the glow plugs?
If you have a inductive amp guage clamp onto harness below glow plug module where it splits off per bank. make sure it's drawing equal. Should be 40-48 amps per side depending on batteries.
Once glow plug cycle ends alt comes on line, batteries only till then!!!
__________________
2006 F250 Lariat SC 4X4, ScangaugeII,CAT EC-1,Sinister coolant filter,blue spring, Atlas40, Updated Turbo lines/stc/standpipes/dummy plugs, DC Power 190 alt., 4"exhaust straight piped, Amp Steps,Die Hard AGM Platinum, Fabtech Radius Arms w/7" D&R Progressive Coils, Rancho 9000XL,Toyo MT 38/15.50/18. 168 lbs of Dyna-Mat,Pad.
Reply With Quote Go to the top
Reply


(View-All Members who have read this thread : 54
03stroker95, 04 f350, 04harley250, 04La4iat, 06 f250 man, 06kingranch37, 2005stroker, 2006powerleaker, 2007PSD, 79puller, 97-7.3powerstroke, amdriven2liv, asatriano, Az07Ford6.0, blackie375, Blown95svt, caleb90, charlez, craig031600, CurlyDE, Dieselboy740, fredwilliamson, Harley Strokin', huck2080, hustler315, jammin60, jrex2506, Justin@DP-Tuner, LBCpowerstroke, leroynasty, Mhatlen, mjcolemn, Nutz, PowerPerformanceChainsaw, Roush4_6, rtc0360, scottrace1, shovle65, Snowbound, sonnyy13n, stroke of luck, stroker_tech, stroking350, tatertot, thestrokin6.0, tireman3, tonyt, toolmangary, truckguy876, twlvftdrdvl, UNRULEE, Vagunter, Wheelhop, wizardofnos
Thread Tools
Display Modes


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 09:34 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.