AC problems! Not blowing strong. - PowerStrokeNation : Ford Powerstroke Diesel Forum


Home Today's Posts Mark Forums Read
Go Back   PowerStrokeNation : Ford Powerstroke Diesel Forum > Super Duty 1999-Current > 6.4L Power Stroke - Technical Info
Register Members List Timeslips Calendar Auto Loans Sponsors Becoming a Sponsor Mark Forums Read Auto Escrow

PowerStrokeNation.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 07-27-2012, 08:33 PM
Evofit300's Avatar
Evofit300
Offline
HTFU
Member's Gallery
 
Join Date: Jun 2012
Location: Blue, Springs, MO
Posts: 48
AC problems! Not blowing strong.

AC system won't blow strong enough to cool the cab down. I took it in to a local mechanic and had them do an AC check. Evaporated system, recharged (was 4 oz low), tested temps (was blowing around 50 degrees), and was told to check a TSB on the DATC. Bought another DATC and plugged it in and no change, so returned it. It's blowing the same out of both sides. Not coming out of the defrost or the floor when set to front vents (just as it is supposed to).

Not sure what else it can be. You can hear it blow harder as you turn the fan up, just blows the same on high as if it were on a medium setting.

Thanks in advance for help.
__________________
2008 F250 CC SB SRW Lariat 4x4 6.4L
Ranch Hand Deer Tenderizer
S&B Cold Air Intake
Mini Maxx with DPF/EGR Delete
18" Weld Velociti with 35x12.50 Toyo Open Country MT
Reply With Quote Quick reply to this message Go to the top
Sponsored Links
Advertisement
 
  #2  
Old 07-28-2012, 05:20 PM
Evofit300's Avatar
Evofit300
Offline
HTFU
Member's Gallery
 
Join Date: Jun 2012
Location: Blue, Springs, MO
Posts: 48
Re: AC problems! Not blowing strong.

Have seen other problems with AC, but seems like this one isn't common. Need to figure out a direction to go next.
Reply With Quote Quick reply to this message Go to the top
  #3  
Old 07-30-2012, 05:50 PM
greaseltn's Avatar
greaseltn
Offline
PSN Veteran
Member's Gallery
 
Join Date: Sep 2009
Location: Hillsborough, NC
Posts: 749
Re: AC problems! Not blowing strong.

You may need to take the fan out and see if a mouse built a nest in the cage. I've seen it before, but usually on a truck that spends alot of time parked.
Reply With Quote Quick reply to this message Go to the top
  #4  
Old 07-30-2012, 06:39 PM
HD-tech-NH's Avatar
HD-tech-NH
Offline
TimmyaleX
Member's Gallery
 
Join Date: Aug 2009
Location: 5150 on 2 wheels
Posts: 656
Re: AC problems! Not blowing strong.

DATC?
__________________
Support Blue Collar Workers

-2008 F-350 XLCCLBSRWZF6
-Fast Idle Switch
-5" DP back
-Innovative livewire
-No Limit
-Newton Fat Boy Traction Bars
-Ebay Leveling Kit
-ICON adj. Trac BAr
-NITTO Terra Grapplers
-Flo Pro EGR delete
-South Bend 3250
-Spartan
-Lab Pit "Stella"

Reply With Quote Quick reply to this message Go to the top
  #5  
Old 07-31-2012, 06:59 PM
Evofit300's Avatar
Evofit300
Offline
HTFU
Member's Gallery
 
Join Date: Jun 2012
Location: Blue, Springs, MO
Posts: 48
Re: AC problems! Not blowing strong.

Dual Automatic Temperature Control
It's the control unit that sits below the radio.

Have recently replaced the belts, tensioner, and idler pulleys, and haven't seen any creature nests. Even sprayed out the fins on the radiator.
Reply With Quote Quick reply to this message Go to the top
  #6  
Old 07-31-2012, 07:38 PM
wynndaddy's Avatar
wynndaddy
Offline
PSN Local
Member's Gallery
 
Join Date: May 2008
Location: TN
Posts: 490
My work truck did this and it had sucked a plastic bag up from the floor and was blocking flow . It would try to change but couldn't complete the cycle . You could hear it blowing hard behind the dash .
__________________
1997 cc swb 4x4
.
Reply With Quote Quick reply to this message Go to the top
  #7  
Old 08-07-2012, 01:49 AM
Evofit300's Avatar
Evofit300
Offline
HTFU
Member's Gallery
 
Join Date: Jun 2012
Location: Blue, Springs, MO
Posts: 48
Re: AC problems! Not blowing strong.

I ran an inspection camera through the vents and found no obstructions .

I read that the evaporator is likely a cause in dusty areas. I bought the truck from Tennessee and there was alot of fine tan dirt in the air filter and all over the truck. So I'm assuming it would probably be beneficial to clean out the evaporator.

Here's the problem, I can't find any good instructors on how to get to it and open it up. Any help would be appreciated.
Reply With Quote Quick reply to this message Go to the top
  #8  
Old 06-17-2013, 02:06 PM
johnnyroastbeef's Avatar
johnnyroastbeef
Offline
PSN Local
Member's Gallery
 
Join Date: Feb 2011
Location: Montgomery County, PA
Posts: 172
Re: AC problems! Not blowing strong.

Quote:
Originally Posted by Evofit300 View Post
I ran an inspection camera through the vents and found no obstructions .

I read that the evaporator is likely a cause in dusty areas. I bought the truck from Tennessee and there was alot of fine tan dirt in the air filter and all over the truck. So I'm assuming it would probably be beneficial to clean out the evaporator.

Here's the problem, I can't find any good instructors on how to get to it and open it up. Any help would be appreciated.
did you ever figure out this issue? My AC seems to be in the same situation not blowing very hard. Just wondering if you ever fixed it and what you determined the cause to be. thanks.
__________________
-'09 F350 CCSB, SRW, 2.5" leveling kit, ICON adjustable track bar, Alradco Radiator, 35/12.5R20 Nitto Trail Grappler, Detroit TrueTrac
Reply With Quote Quick reply to this message Go to the top
  #9  
Old 12-02-2014, 02:11 AM
Evofit300's Avatar
Evofit300
Offline
HTFU
Member's Gallery
 
Join Date: Jun 2012
Location: Blue, Springs, MO
Posts: 48
Re: AC problems! Not blowing strong.

Hopefully you have fixed the problem. I haven't been on in a while. For others looking for the resolve. My evaporator was dirty.

I removed the glove box and behind it is a large black box. To save myself the trouble, I cut about a 3"x3" square in it with a razor knife. I used a/c condenser cleaner (from home depot for home a/c units). I sprayed that inside and let it sit for a couple minutes. then with a spray bottle of water rinsed it all out. Make sure it drains out of the drain tube that sits behind the air filter box. If not, stick something in there to unclog it. I cut out a piece of aluminum to cover the whole, ran a bead of silicone around it, a screwed it on. Has held up for over a year with no problems.
Reply With Quote Quick reply to this message Go to the top
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




(View-All Members who have read this thread : 106
01strokin, 03f250powerstroke, 03sixspeed, 086.4xcab, 44magnum, 6.4power, 8nout, aamartin89, ARCTICCAT, B. Adams, birddog55, Black 4.6 Beast, Blackharleyf250, BMFF350, bradleyscott, Brichmond, btaylor08, chris d, coopers_dad, Cowboyup, cummin5.9strokin6.0, CUMMINS_KILLA99, daddystoy, dbs0026, dburton, Deere8420, deereman, DenisTheMenace, Denver, DieselDZ, Doc_Ron, drh4250, Evofit300, flightmedic571, fordpowerf450, Gefell, goosyboy, greaseltn, harleydf250, HD-tech-NH, henline06, Honey Badger, icanski2, ikoen, Imh519, iowacornfarmer, Jameso, JD3020, JOHN BOLT, Johnny77Mutt, johnnyroastbeef, justin51986, jwatrous, KingRanch4x4/6.4, KPBJJ, LILGSX, lowbedriver, Luther's 2008, Map22, max2006, michaelelcano, Mmecsics, monjeepster, MrBill1, Mudlight, Muledude, Mustang mike 93, mydually, NickNasty18, Nomad1671, OBSpstroke97, obsstroker95, OilBoy, Pan4905, pooter, powersmokin64, powerstroke6.4, powerstrokef2fiddy, reason, RJC2, Robs94z, rock_doctor, rollininmy64, rudyfontana30, scott2001, silverstroker08, skeetreecetw, skobiak, slang23488, slyfly76, smokin99stroke, snopro_69, Stang07, Steinbrenner, stephendudra, Sti470, texasboy91, TheBeast7.3, theGreenHornet, tisbister, Tlink, Uncle Buck, whudson, Wizzard of Odds
Thread Tools
Display Modes


Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:21 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.