Hard start, rough running 94 7.3 - PowerStrokeNation : Ford Powerstroke Diesel Forum


Home Today's Posts Mark Forums Read
Go Back   PowerStrokeNation : Ford Powerstroke Diesel Forum > F-250 & F-350 1986-1997 & Other Ford Trucks > 1994-1997 Power Stroke Technical Info
Register Members List Timeslips Calendar Auto Loans Sponsors Becoming a Sponsor Mark Forums Read Auto Escrow

PowerStrokeNation.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 04-25-2012, 03:50 AM
Mustangranch22's Avatar
Mustangranch22
Offline
PSN Local
Member's Gallery
 
Join Date: Jun 2010
Location: Peyton, CO
Posts: 133
Hard start, rough running 94 7.3

Ok I just picked up a 94 7.3l. I have a few different issues/questions. When I got the truck the hpop leaked like crazy. Pulled it off and happened to pick up a 99 hpop. Did the swap with the drain back mod that I found on here. Truck still starts hard!!! All glow plugs are good. Harness under the valve covers are good. Once you get the truck started it idles horrible. (oh I changed the oil to 5w40 synthetic rotella) I put a temp gun on the manifolds. 3 cylinders are dead cold while it idles. Once it warms up its like a light switch gets flipped and the truck rins better than my 97 did I'm stuck on where to start with my diag. My scanner won't talk to the PCM, so I can't run a buzz test or watch cranking oil psi etc. Trying to decide if I have an oil system issue or some injectors bad. (sorry shoulda mentioned truck has 250k and I think they didn't do good pm on it). So do I send te PCM in and have it flashed to be obII compatible? Which if I do that who is good to send it to. Or try to find a 97 PCM? I know that'll help to diag obviously. Just curious too if there's any known oil issues in the oil system in the heads or anything. Thanks in advance since this has prob been asked 100 times.
__________________
Hot Rods:
1994.5 F-350 4x4 Powerstroke
1939 9N Tractor
1966 Chevrolet Chevelle SS

B&W Turnoverball Dealer
Reply With Quote Go to the top
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
  #2  
Old 05-01-2012, 09:55 PM
Mustangranch22's Avatar
Mustangranch22
Offline
PSN Local
Member's Gallery
 
Join Date: Jun 2010
Location: Peyton, CO
Posts: 133
Re: Hard start, rough running 94 7.3

Ok I picked up a pcm out of a 96 cheap so I'm going to plug it in and see if I can run the buzz test with it. I found another post on here somewhere that had the same numbers as mine and said that it should work to do so. I think #1,4,8 injectors are bad so heres hoping I can confirm with the buzz test.
Reply With Quote Go to the top
  #3  
Old 05-01-2012, 10:01 PM
countryboyrob
Offline
PSN Veteran
Member's Gallery
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,537
Re: Hard start, rough running 94 7.3

Why did you post in the SD section?
__________________
02 f250
Reply With Quote Go to the top
  #4  
Old 05-01-2012, 10:05 PM
Mustangranch22's Avatar
Mustangranch22
Offline
PSN Local
Member's Gallery
 
Join Date: Jun 2010
Location: Peyton, CO
Posts: 133
Re: Hard start, rough running 94 7.3

Quote:
Originally Posted by countryboyrob View Post
Why did you post in the SD section?
You got me damn it! I always seem to do that.
Sorry
Reply With Quote Go to the top
  #5  
Old 05-01-2012, 10:11 PM
countryboyrob
Offline
PSN Veteran
Member's Gallery
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,537
Re: Hard start, rough running 94 7.3

Quote:
Originally Posted by Mustangranch22 View Post
You got me damn it! I always seem to do that.
Sorry
Click thread tools and move thread.
Reply With Quote Go to the top
  #6  
Old 05-01-2012, 10:18 PM
Mustangranch22's Avatar
Mustangranch22
Offline
PSN Local
Member's Gallery
 
Join Date: Jun 2010
Location: Peyton, CO
Posts: 133
Re: Hard start, rough running 94 7.3

Quote:
Originally Posted by countryboyrob View Post
Click thread tools and move thread.
There we go...sorry thought only moderators could do that.
Thanks
Reply With Quote Go to the top
  #7  
Old 05-01-2012, 10:21 PM
countryboyrob
Offline
PSN Veteran
Member's Gallery
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,537
Re: Hard start, rough running 94 7.3

Try the pcm yet?
Reply With Quote Go to the top
  #8  
Old 05-02-2012, 01:02 AM
Mustangranch22's Avatar
Mustangranch22
Offline
PSN Local
Member's Gallery
 
Join Date: Jun 2010
Location: Peyton, CO
Posts: 133
Re: Hard start, rough running 94 7.3

Quote:
Originally Posted by countryboyrob View Post
Try the pcm yet?
Well no. Instead I read somewhere I could just put it into my scanner as a 96 and see if they'd communicate. So I tried that just now. Showed inj pressure hen the truck was cranking 175 rpm's to be 3000. Ran a buzz test it showed system pass. I plugged the glow plug relay in and the truck fires up but misses just as bad as ever. Watched inj psi at idle was 800 ish dyer to came back down from 3000. Truck doesn't appear to drinking oil so not sure if I should re prong the injectors that are cold? I checked them with a temp gun is how I figured which ones I assume are bad. I wanna fix it right not just throw parts at it while I learn.
Reply With Quote Go to the top
  #9  
Old 05-10-2012, 10:13 PM
Mustangranch22's Avatar
Mustangranch22
Offline
PSN Local
Member's Gallery
 
Join Date: Jun 2010
Location: Peyton, CO
Posts: 133
Re: Hard start, rough running 94 7.3

anybody know will there be any advantage to swapping the 96 PCM in my truck since the current PCM will communicate with my scanner if i enter it as a 96?
Reply With Quote Go to the top
  #10  
Old 05-11-2012, 02:13 AM
Patrick Feeley's Avatar
Patrick Feeley
Offline
PSN Veteran
Member's Gallery
 
Join Date: Mar 2008
Location: Tehachapi, CA
Posts: 1,996
Re: Hard start, rough running 94 7.3

If they are both for the same transmission, you could use it, but there would probably be no real advantage. You would need to clear any codes once its installed and then see what pops back up.
__________________
97 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, Ext Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD: 94 F350 CC DRW PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, 3 DP, Bilsteins, $12 AIC, Coolant Filter, Explorer O/H Console, Trans Temp, Boost, and Pyro, Pedestal Mod, Gutted EBPV
Reply With Quote Go to the top
Reply


(View-All Members who have read this thread : 84
350blk6.0, 6869704x4, 7.3L F-250, 79schaefer, 94youngturbo, 96BlackOBS, adrenalinejunky81, Alvapowerchoke, AZStang, a_port93, bpa658, Brian918, Bugman, cabloom7.3, ccf350stroker, Cutty72, dag4566, Deererainman, Dirtyboy82, DragginAssphalt1, drkndzl22, dsinderson, dxp200, Ethan218, FarmBoyStroker, floridastroke, Force2354, Fordguy26, foxco44, Gaius, Gallo, garden_grub, gmdriscoll, gould9, harley1iron, Haztanker, helo1, hotshoe91m, hunter scar, jkrum10238, kh_strokin07, King Valley, klos, lincolnlocker, madpogue, martinique78, MidwestOBS, milehighstroker, monster-energy-825, Mr.Wonderful, Mustangranch22, njjeep, Nodge, nujef12, old man dave, otis62888, Patrick Feeley, Patrolman, powersmoker73, p_stroke_1, quartershot, rafter3w, redneckboarder, Richardi503, ScedRanger, ShogunRider, Shovel, Shrub, slushman06, snoel123, snoopdog, spok, stoneykegonsa, stroker1999, Strokin450, texasredneckjae, tougas, TravisT, trykillthis, wb589, Wilson444, Wood Kutter, Zrock
Thread Tools
Display Modes


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:01 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.