Truck loses power and stalls going up hills - PowerStrokeNation : Ford Powerstroke Diesel Forum


Home Today's Posts Mark Forums Read
Go Back   PowerStrokeNation : Ford Powerstroke Diesel Forum > F-250 & F-350 1986-1997 & Other Ford Trucks > 6.9 - 7.3L IDI Diesels 83-93 Model Years
Register Members List Timeslips Calendar Auto Loans Sponsors Becoming a Sponsor Mark Forums Read Auto Escrow

PowerStrokeNation.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 01-04-2012, 09:10 PM
sixshooter
Offline
PSN Newb
Member's Gallery
 
Join Date: Oct 2011
Posts: 22
Truck loses power and stalls going up hills

I have a 1994 Centurian turbo 7.3 IDI. It sat for about a year or so before I got it. It has 102,000 miles on it, and I just got it about a month ago. I have put about 2000 miles on it, and the first 1500 had no issues what so ever other than a little bit of water in the bottom of the fuel filter twice (I check it all the time to make sure). I replaced the fuel filter right after I got it once I saw that there was a decent amount of water in the separator and I had no idea when it had been replaced last. I replaced it a second time when the fuel filter light in the dash came on. I drove the truck with no issues and towed with it all over the place, no issues. Then as we are going to get our Christmas tree, as we start going up hills, it starts sputtering every hill we hit, with the fuel filter light coming on, then going off when we go down the hills...and clearing up. We made it home and the truck seemed okay, so I went to drive it the next day and I go to drive it home from a job and it just stopped running. It seemed like it ran out of fuel, so I went got fuel and put it in and it seemed to start okay so I started home. I got to the first hill and it died, restarted it and drove the rest of the way up the hill, and drove all the way to the next hill, and so on, until I hit a hill and it did not start again. I had to have it towed because it just would not start. I changed the filter again, got it started but on the very first hill, it stalled. I got it started, and got it home, but I am afraid to drive the thing until I know what is going on. Sorry this is so long winded, I just wanted to be thorough.
Reply With Quote Go to the top
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
  #2  
Old 01-04-2012, 11:41 PM
DarkHorse89's Avatar
DarkHorse89
Offline
Sofa King Awesome.
Member's Gallery
 
Join Date: Sep 2011
Location: Sturgis, South Dakota
Posts: 20
Re: Truck loses power and stalls going up hills

Well, it sounds to me like you're getting some air intrusion. It could also be that the mechanical lift pump is starting to fail. Have you purged the schrader valve on the filter head to see if you've got air in the fuel? If not, do that and see. My truck did something simillar and it turned out to be the lift pump. I'm not quite sure how the hills would be affecting it though Oh well, hope this helps.
__________________
-Clint

1990 F250 Ex cab 7.3 ZF5 NA
1995 F-250 7.3 PSD ex-cab. A "few" mods.
1994 F250 Ex cab 7.3 ZF5 ats factory turbo. Now parts truck.
1975 F-250 4X4 390 + 4-speed.
1989 F250 5.8 Five Speed Dew-Eze Bale carrier.
1984 F-150 4X4 300-6, 4-speed.
1992 Mercury Grand Marquis
2000 Lincoln Towncar. Wrecked!
Reply With Quote Go to the top
  #3  
Old 01-05-2012, 01:05 AM
f350dualie's Avatar
f350dualie
Offline
PSN Local
Member's Gallery
 
Join Date: Nov 2011
Location: Des Moines IA
Posts: 298
Re: Truck loses power and stalls going up hills

when you hit a hill you give it more throttle and the engine has a greater load which means more fuel from the lift pump
it does sound like a lift pump starting to go out

you should be able to get a lift pump for about 30 bucks (rock auto.com had one for 28.99 plus shipping)

and what is a Centurian
Reply With Quote Go to the top
  #4  
Old 01-05-2012, 02:22 AM
NMB2's Avatar
NMB2
Offline
IDIot
Member's Gallery
 
Join Date: Jul 2011
Location: Denver, CO
Posts: 1,767
Send a message via Yahoo to NMB2
Re: Truck loses power and stalls going up hills

Quote:
Originally Posted by f350dualie View Post
and what is a Centurian
Really?
Reply With Quote Go to the top
  #5  
Old 01-05-2012, 02:47 AM
f350dualie's Avatar
f350dualie
Offline
PSN Local
Member's Gallery
 
Join Date: Nov 2011
Location: Des Moines IA
Posts: 298
Re: Truck loses power and stalls going up hills

never seen one before i had to google it
Reply With Quote Go to the top
  #6  
Old 01-05-2012, 05:30 AM
sixshooter
Offline
PSN Newb
Member's Gallery
 
Join Date: Oct 2011
Posts: 22
Re: Truck loses power and stalls going up hills

I am new to these and the only thoughts we had were that the lift pump was going bad. It seemed to be the only thing that made sense because the filter was new and the idiot light for the filter keeps coming on going up hill and going off on the flat or going down hill (which I assume the light is just a pressure drop sensor) so it had to be something before the sensor....but being a newbie I didnt want to just start changing parts without going to the sources first. I will change the pump when it is above 12 degrees here. Thanks
Reply With Quote Go to the top
Reply


(View-All Members who have read this thread : 38
6.9performance, 7.3L F-250, 91forddiesel, 92f350cc, 93crewcab, 94iditrbo, 96f350psd, bfoster, blackmagic, cdnf250, Cincinnati Guy, Csulli250, DarkHorse89, DeadMan, DieselJuice, doofpowerstroke, Dusty Roads, f350dualie, Hick and Tick, j.soffa, jcspowerstroke, jdgleason, Jjona5, jmjc123, LaWrench, McFadin(BACON), mo idi, NMB2, OBSIDI, optikalillushun, sixshooter, Sockwell10, stevedrums, stroker1996, wbrett1027, Wicked97
Thread Tools
Display Modes


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:22 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.