After EGR, Low Boost? - PowerStrokeNation : Ford Powerstroke Diesel Forum


Home Today's Posts Mark Forums Read
Go Back   PowerStrokeNation : Ford Powerstroke Diesel Forum > Super Duty 1999-Current > 6.0L Power Stroke Technical Info
Register Members List Timeslips Calendar Auto Loans Sponsors Becoming a Sponsor Mark Forums Read Auto Escrow

PowerStrokeNation.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 12-04-2011, 01:21 AM
19_A_LT's Avatar
19_A_LT
Offline
Bandwagon Jumper
Member's Gallery
 
Join Date: Jun 2009
Location: Canelo, AZ
Posts: 293
After EGR, Low Boost?

Got my truck back from my shop after doing my full EGR delete and it seems like it is running lower boost and missing a few horses than before. Is this normal? They rechecked all the boots and clamps. The EGR is still in and plugged in, but the uppipe was changed and cooler deleted? No codes/lights. What else could cause this?
__________________
1999 Dodge 2500 ECLB 24V Cummins, 2wd AT, 115k miles. 4" Straight, AFE Dry Filter *For Sale*
Reply With Quote Quick reply to this message Go to the top
Sponsored Links
Advertisement
 
  #2  
Old 12-04-2011, 07:11 PM
Zmann's Avatar
Zmann
Offline
PSN Veteran
Member's Gallery
 
Join Date: Nov 2010
Posts: 7,929
Re: After EGR, Low Boost?

? check the VGT connector on the turbo but I would think youd code for low boost?
__________________
O6 King Ranch cc sb 8 inch lift ,37 Toyo's,Helo’s Edge Insight CTS guage only , Auber EGT , o8 center console , xm satellite ,coolant filter,RSX 9000 shocks,dual TGC dual steering stabilizers ,Viper , remote toolbox popper, High Idle mod , $ link Rize , ARP's, BPD EGR cooler, Fabtech traction bars, Tony's tune
Reply With Quote Quick reply to this message Go to the top
  #3  
Old 12-06-2011, 10:16 AM
19_A_LT's Avatar
19_A_LT
Offline
Bandwagon Jumper
Member's Gallery
 
Join Date: Jun 2009
Location: Canelo, AZ
Posts: 293
Re: After EGR, Low Boost?

The connector is good and working. The shop even repaired part of the wiring harness going to it. Before the EGR delete, it would make upwards and sometimes over 20psi boost. Now i can hardly get it over 10 pounds when i put the skinny pedal down. My 03 did the same sorta, but i blamed it on not putting the new uppipe in. I am stumped on this new one though.
Reply With Quote Quick reply to this message Go to the top
  #4  
Old 12-07-2011, 07:32 PM
mcdaniel1991's Avatar
mcdaniel1991
Offline
PSN Local
Member's Gallery
 
Join Date: Jul 2011
Location: Grafenwoehr, Germany
Posts: 127
Re: After EGR, Low Boost?

what brand Delete did you use? i just finished deleting my 06 and i used sinisters kit it was a pain in the A@# but i think im getting higher boost then before!?
__________________
2006 F-250 XLT FX4 PSD 180,000 Mi
Leveled, Innovative and Gearhead tunes, BPD 58v 6 Phase FICM, Straight exhaust, Sinister EGR/COOLER delete, Sinister Coolant Filter, Mobile 1 5w 30, Zoodad
Reply With Quote Quick reply to this message Go to the top
  #5  
Old 12-13-2011, 02:41 AM
19_A_LT's Avatar
19_A_LT
Offline
Bandwagon Jumper
Member's Gallery
 
Join Date: Jun 2009
Location: Canelo, AZ
Posts: 293
Re: After EGR, Low Boost?

I used custom diesels kit. It has the block off plate as well as the uppipe.. Is it common for the Turbos to gum up while performing deletes?
Reply With Quote Quick reply to this message Go to the top
  #6  
Old 12-13-2011, 02:49 AM
ksieckmann's Avatar
ksieckmann
Offline
Gambled and Lost 6.oh
Member's Gallery
 
Join Date: Aug 2011
Location: Midwest - where we love the USA
Posts: 927
Re: After EGR, Low Boost?

If your only getting 10psi surely you would get a low boost cel
__________________
'05 CCSB FX4
Deleted, Studded, SCT w/ Vivian's Looney Wild, Warrens 190cc. DieselRX

Performance-Fueling.com
Reply With Quote Quick reply to this message Go to the top
  #7  
Old 12-13-2011, 02:53 AM
CTC DEEZUL's Avatar
CTC DEEZUL
Offline
Hood Rich
Member's Gallery
 
Join Date: Sep 2010
Location: NW Indiana
Posts: 2,873
Send a message via AIM to CTC DEEZUL
Re: After EGR, Low Boost?

recheck y pipe connection at turbo...
__________________
NWI Coal Rollers Association

Local 444- Rolling Coal Teamsters
via Beans Toonz
DI SS Up-Pipe
GTP38R
Reply With Quote Quick reply to this message Go to the top
  #8  
Old 12-13-2011, 03:53 AM
maps
Offline
PSN Newb
Member's Gallery
 
Join Date: Dec 2009
Location: Michigan
Posts: 34
Re: After EGR, Low Boost?

20 PSI prior to the delete still seems a little on the low side to me. I am not tuned and will see 29 to 30 PSI at WOT.
__________________
2003 Super Duty 6.0L 4x4 SC/SB. Coolant filter, exhaust, gauges, CTS with some other stuff

Pulling a 35' KZ Sportster toy hauler
08 KTM450XCW-R
2000 CR500AF
1990 CR500
Reply With Quote Quick reply to this message Go to the top
  #9  
Old 12-13-2011, 07:34 AM
mgeistman's Avatar
mgeistman
Offline
matt
Member's Gallery
 
Join Date: Nov 2011
Location: victoria texas
Posts: 911
Re: After EGR, Low Boost?

__________________
4'' exhaust, egr delete, upgraded oil cooler, arp studs,50mm BOV, volant CAI, 66/73/.91 turbo, 205/100 injectors, crossover fuel line, airdog II, sct by TSD & ID, high idle mod, nitrous express with .092 jet, 26 GPH water/meth, ats stage 3 tranny, king Ranch front and rear captins chairs, and of course kicker sound system
Reply With Quote Quick reply to this message Go to the top
  #10  
Old 12-13-2011, 12:24 PM
19_A_LT's Avatar
19_A_LT
Offline
Bandwagon Jumper
Member's Gallery
 
Join Date: Jun 2009
Location: Canelo, AZ
Posts: 293
Re: After EGR, Low Boost?

I don't hit WOT very often; I baby the hell outta it. I know it definately is a dog after the EGR Delete. I also threw a Low Boost Code.
Reply With Quote Quick reply to this message Go to the top
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




(View-All Members who have read this thread : 104
03kingranchstroke, 04krpsd, 06PowerstrokeFX4, 19_A_LT, 2 Stroker, 2005stroker, 2ndHandSmoke, 4.0l sahara, 6.0stroken, 6L strokin, 907DAVE, 96f350psd, 97F250 HD, 97psd16.5mpg, acplowboy84, bassrippin365, bigrngyj, Blue, Bri, brute_mt, buc1096, bzy livn, cat420e, cavscout075, chainsaw, Chuck999, CTC DEEZUL, cummins kid, damons250, dauntejoel, Dave, Dave-pls, dave_k96, ditchdoc, dunnie67, eviljarv, Falls250, FATHERFORD, fiveohcrazy, football3295, From384, FTREE50, Harley Strokin', hill_billiez, Honda30, huntingcrazzy, hystrung2xpi, Ian123, Ignorant1, jimmyb, Jomull55, JonnyB, ksieckmann, LAXipad, liftedsilver250, Loonatic, Lupe.R, majek5, mandkole, maps, mcdaniel1991, Mcfly89, mgeistman, mmm635, New6.0PSOwner, NH OIL BURNER, nickPSD, Niwrek, NYC F-350, pappy42, Petro, pizza pig, pyro6999, Rambler, Rhys05, rileyrs, rollingcoal69, rossi48, SaNnDnSurF, shadow6.0, SKEETERMAN03, slvr bullet, Springnook, Strokin304, svorob, svtdiesel, tbrama, Techtime20, toycrawler, treetechsixOH, turboculosis, Turbodiesel6.0, turboteeljr21, UNRULEE, Visionpro_Xenon, Wangfu12, WCH_diesel, webb06, wiltface, yodermanks, Zane-03 King Ranch, Zmann
Thread Tools
Display Modes


Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:35 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.