7.3L Has no power - PowerStrokeNation : Ford Powerstroke Diesel Forum


Home Today's Posts Mark Forums Read
Go Back   PowerStrokeNation : Ford Powerstroke Diesel Forum > Power Stroke Nation! > New To The Nation
Register Members List Timeslips Calendar Auto Loans Sponsors Becoming a Sponsor Mark Forums Read Auto Escrow

PowerStrokeNation.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 09-04-2011, 05:55 PM
69Porterj
Offline
PSN Newb
Member's Gallery
 
Join Date: Sep 2011
Posts: 3
7.3L Has no power

What up, I am new to this forum and need some help/

my 2000 F350 seems to have lost its getty up. I was pulling a 69F250 on a deck over trailer the other day and the truck stalled out on me on a little hill. When I got it started and going again excessive black smoke came out. I stopped about two miles later and put it in nuetral to blurp the throttle a bit to see if something was acting up. I heard some really clacky noise coming out the exhaust and then it went away.

From there I cant get any smoke build up when I down shift and step on it and I have little to no boost on my turbo gauge. Turbo temp is around 900 even when I am trying to accelerate.

I put an IR gun to the cyclinders and found left front cylinder is 30-40 degrees colder then the other 7. I need help confirming that I in fact have a blown injector or that my turbo has failed before I buy parts and start swapping things out.

With the hood open I can hear a noise difference from the driver and passenger side of the motor. It is more pronounced on the driver side.

any help is appreciated.
Reply With Quote Go to the top
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
  #2  
Old 09-04-2011, 06:11 PM
powerstroke02's Avatar
powerstroke02
Offline
PSN Local
Member's Gallery
 
Join Date: Jul 2008
Location: Racine, WI
Posts: 278
Re: 7.3L Has no power

take your intake off and look at the inlet of the turbo and see if there is something that doesn't look right, if it looks ok pull back and forth on the compresser wheel and see if there is any play there.
im thinking u blew the turbo by what it sounds but we could use a little more detail
__________________
2002 psd,4x4 ECSB
DP-TUNED
4" lift 35" tires
3.73 gears
cervinis 3" cowl hood
fuel pressure-pyro-trans-boost
Full 4" exhaust
K&N fipk
Strictly diesel "bowl delete" regulated return
FASS system
cutsom built trans
stealth stage2 (big oil)
di's up pipes
38r with wicked wheel 2
6.0 trans-cooler
ccv moved
swamps modded idm
Reply With Quote Go to the top
  #3  
Old 09-04-2011, 06:25 PM
69Porterj
Offline
PSN Newb
Member's Gallery
 
Join Date: Sep 2011
Posts: 3
Re: 7.3L Has no power

Thanks, I will check that out and let you know what I find. What other information can I gather to help diagnosis?
Reply With Quote Go to the top
  #4  
Old 09-05-2011, 07:18 PM
69Porterj
Offline
PSN Newb
Member's Gallery
 
Join Date: Sep 2011
Posts: 3
Re: 7.3L Has no power

took the intake off and inspected the impeller. The blades look like they are in great shape. I grabbed the center post and shook it only to find there was probably on a mm or so of movement if that. I felt the housing walls for damage as well and couldnt find any.

Drove the truck again today and it seemed to run fine but it is still making that weird ticking sound on the driver side. Sounds different then the clicking on the passenger side.

How can I test the injectors without taking the truck to Ford?
Reply With Quote Go to the top
  #5  
Old 04-05-2012, 11:00 PM
mrforklift
Offline
PSN Newb
Member's Gallery
 
Join Date: Apr 2012
Posts: 4
Re: 7.3L Has no power

sounds like #8 injector(on the drivers side rear) replace and should fix it
Reply With Quote Go to the top
  #6  
Old 04-05-2012, 11:39 PM
NE-STROKE's Avatar
NE-STROKE
Offline
I like turtles
Member's Gallery
 
Join Date: Nov 2009
Location: omaha Ne
Posts: 2,577
Re: 7.3L Has no power

Any exhaust leaks out of manifolds or up-pipes? Low drive pressures cause low boost and high egts.
__________________
08 duramax ccsb efi live, air dog 2, isspros, 5 inch exhaust and some other cool things. 2001 duramax 2wd (Project truck)
Once had a signature that had some bad ass stuff on it. Now its back to crap.
Reply With Quote Go to the top
Reply


(View-All Members who have read this thread : 51
2000 powerstroke7.3, 5 speed, 69Porterj, 97strkr, bhuntt, Bushwakd, Bustedknuckles, camilo, CANNONMAN, chassross2003, clp13294, coyote1, David N, Desertdweller, DUESLER, DZLAL, ghohouston, gilly, going for 400000, Greyliner1, Hoss1997, IL7.3 Powerstroker, jbarlow15, keep'erpinned, KYkickinit, loudmouth, mgeod, monster-energy-825, mossyoakmudslinger, mrforklift, mttrucker, mx250racer1, NE-STROKE, outlaw 4017, Plumbnman, Plumkrzy, powerstroke02, Powerstroke1997, powerstroke3, pwr73stroke, Skew12, spadone, steinerr, strokinfarmtruck, thatjerk01, tughill283, WoodBoy, wrenchturner250
Thread Tools
Display Modes


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:42 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.