Anyone use Wagner ThermoQuiet Brake Pads????? - PowerStrokeNation : Ford Powerstroke Diesel Forum


Home Today's Posts Mark Forums Read
Go Back   PowerStrokeNation : Ford Powerstroke Diesel Forum > F-250 & F-350 1986-1997 & Other Ford Trucks > 1994-1997 Power Stroke Technical Info
Register Members List Timeslips Calendar Auto Loans Sponsors Becoming a Sponsor Mark Forums Read Auto Escrow

PowerStrokeNation.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 09-01-2011, 01:43 AM
metrojd
Offline
PSN Local
Member's Gallery
 
Join Date: Oct 2009
Posts: 420
Question Anyone use Wagner ThermoQuiet Brake Pads?????

My CC needed ft Pads..
Bought Wagner ThermoQuiets..
Put them on with out cutting the rotors..
Dosent seem to want to stop...
Actually rolled thru a light almost with my enclosed trailer on..
Front brakes were porring Smoke off after that..

Pulled the pads and they look smoth as Glass..

Pulled the rotors and had them cleaned up, touched the pads up on a belt sander and put back together..

Still seem like it dosnt want to stop..

Def. cant do a panic stop...


So....
What do ya think??
Pads??
or What??

Thanks
John
Reply With Quote Go to the top
Sponsored Links
Advertisement
 
Sponsored Links
Advertisement
 
  #2  
Old 09-01-2011, 02:02 AM
loudmouth
Offline
PSN Local
Member's Gallery
 
Join Date: Sep 2010
Posts: 472
Re: Anyone use Wagner ThermoQuiet Brake Pads?????

I've had them on mine for about a year, no issues. What did the old pads look like, any uneven wear?
Reply With Quote Go to the top
  #3  
Old 09-01-2011, 02:03 AM
Matt07
Offline
PSN Local
Member's Gallery
 
Join Date: Dec 2010
Posts: 317
Re: Anyone use Wagner ThermoQuiet Brake Pads?????

Did you have problems stopping before you put those pads on?
Are the new pads ceramic or semi metalic?
Reply With Quote Go to the top
  #4  
Old 09-01-2011, 02:08 AM
metrojd
Offline
PSN Local
Member's Gallery
 
Join Date: Oct 2009
Posts: 420
Re: Anyone use Wagner ThermoQuiet Brake Pads?????

Quote:
Originally Posted by loudmouth View Post
I've had them on mine for about a year, no issues. What did the old pads look like, any uneven wear?
Old pads were wore out, evenly...
Reply With Quote Go to the top
  #5  
Old 09-01-2011, 02:11 AM
metrojd
Offline
PSN Local
Member's Gallery
 
Join Date: Oct 2009
Posts: 420
Re: Anyone use Wagner ThermoQuiet Brake Pads?????

Quote:
Originally Posted by Matt07 View Post
Did you have problems stopping before you put those pads on?
Are the new pads ceramic or semi metalic?
I dont rember having any problems>>

I believe they are ceramic..
Reply With Quote Go to the top
  #6  
Old 09-01-2011, 02:25 AM
Matt07
Offline
PSN Local
Member's Gallery
 
Join Date: Dec 2010
Posts: 317
Re: Anyone use Wagner ThermoQuiet Brake Pads?????

hhmm, sounds to me like it's the new pads then, which is unusual. The rotors didn't happen to have a film of grease or some other kind of residue on them did they? I know you said you cleaned them up....
If the rotors are clean then I would say its in the pads...not really sure what would cause them to become so smooth other than poor quality. Take em' back and try a different set is what I would do.
Reply With Quote Go to the top
  #7  
Old 09-01-2011, 01:29 PM
metrojd
Offline
PSN Local
Member's Gallery
 
Join Date: Oct 2009
Posts: 420
Re: Anyone use Wagner ThermoQuiet Brake Pads?????

From what I am reading they arent ThermoQuiets....

Found thr box end that I kept..
They are Wagner Severe Duty
SX450
Semi Metallic.
Reply With Quote Go to the top
  #8  
Old 09-01-2011, 03:03 PM
rolsmojave3's Avatar
rolsmojave3
Offline
PSN Local
Member's Gallery
 
Join Date: Jun 2010
Location: Wisconsin
Posts: 210
Re: Anyone use Wagner ThermoQuiet Brake Pads?????

Sounds like the rotors were glazed, now the pads are glazed. So, you corrected that issue. I would go attempt to bed them in without a trailer. Also make sure the rear shoes are adjusted correctly.
__________________
97' F-350 7.3 5 speed, K&N intake, stacks, some sort of tune.
Reply With Quote Go to the top
  #9  
Old 09-01-2011, 03:18 PM
metrojd
Offline
PSN Local
Member's Gallery
 
Join Date: Oct 2009
Posts: 420
Re: Anyone use Wagner ThermoQuiet Brake Pads?????

Quote:
Originally Posted by rolsmojave3 View Post
Sounds like the rotors were glazed, now the pads are glazed. So, you corrected that issue. I would go attempt to bed them in without a trailer. Also make sure the rear shoes are adjusted correctly.
I did check the rear and adjusted them a little..
Still just seems like it takes a while to stop.

If I push on the pedal as hard as passiable it seems just to keep going..
Pedel isnt hard,,
Just dosent seem right,,
Reply With Quote Go to the top
  #10  
Old 09-01-2011, 03:45 PM
spstactical's Avatar
spstactical
Offline
PSN Local
Member's Gallery
 
Join Date: May 2011
Location: NJ
Posts: 248
Re: Anyone use Wagner ThermoQuiet Brake Pads?????

I'm not a fan of new pads on old rotors with either cutting them or atleast taking some sand paper to them to get the glaze off....( not the correct way, but it works)

Your new pads are shot!!!

Start over!!
__________________
1996, F350, CCLB, 7.3, Auto, 3" DP to 4" straight pipe...
TS 6 pos chip....
3 gauge pod with autometer gauges...
9.5" lift ...
80" Ladder bars...
37"s....
2008 Diff cover ( glassbeaded and cleared)
Reply With Quote Go to the top
Reply


(View-All Members who have read this thread : 85
'94IDITurbo7.3, 444CuiOBS, 6.0_psd, allegheny, barney1, Bergy1, BoomerL37, Bradbilt, Bulldog, Bushwakd, cadwell08, Centxdiesel, Copperhead, cozzb, DaveBey, dermestid, ding1968, DougN, dsinderson, dzlj 50, eleventhtruck, ericlouie1, EverettWV, ford97, ford_trck, FSJPat, graywolf, Greger96obs, haddixj, hendricksbus, Hijo202, iluv83vettes, Jason.Horath, jclem, jcmagone, Jjona5, johnboy1861, johndeereman, JRF, jschildm, K5383, kade625, krafty, lossscause, loudmouth, madmaxz, majek5, mandkole, Matt07, MB97PSD, metrojd, Mini-Stroke..., mj250, mojoman, Moosefps, morefuel, mxredneck, otis_301, Patrolman, pff250hd, rancherstroker6, raptor, rickvm, RockinJW, rolsmojave3, rusty1161, salprofish, San Antonio 78, sg465, snoblade82, specca, spstactical, STROKER #1, swaggs321, SWVa, toolmangary, turboaz2, unimog1300, weekendwarriorfsw32, White6.0PS, wint, zacattack4x4, zilla68
Thread Tools
Display Modes


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:27 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.