1997 F250 problem - PowerStrokeNation : Ford Powerstroke Diesel Forum


Home Today's Posts Mark Forums Read
Go Back   PowerStrokeNation : Ford Powerstroke Diesel Forum > F-250 & F-350 1986-1997 & Other Ford Trucks > 1994-1997 Power Stroke Technical Info
Register Members List Timeslips Calendar Auto Loans Sponsors Becoming a Sponsor Mark Forums Read Auto Escrow

PowerStrokeNation.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
  #1  
Old 06-10-2011, 08:23 PM
j.soffa's Avatar
j.soffa
Offline
DieselAddict
Member's Gallery
 
Join Date: Jan 2011
Location: Eastern Wisconsin
Posts: 63
1997 F250 problem

While driving to work a few hours ago my truck just died in the middle of driving. Started right back up while coasting and check engine light came on. 5 seconds later disappeared. Just swang by autozone to get a code, but they said nothing was logged. I've noticed that within the past couple weeks my idle has been degrading. very choppy. Also my voltage meter on my dash started acting funny. It started not moving as far after the glow plugs finish (usually was around the m and a, and will just randomly pick a spot every time I run the truck. Still seems to be charging the batteries... i think. Had it tested at autozone, they said it was fine. Only recent change was a cruise control recall and oil change 5 days ago.

Any input would be helpful. Just at work now. Thanks!

Truck has a 5 month old 250 amp alternator
2month old batteries
New Starter
New Stancor GP relay, all GP's check fine.
Black CPS 2 months ago

trucks got 240,000 on the clock.
__________________
1995 F350 7.3L T444E (not powerstroke) Stage 2 Inj, Terminator HPOP, TS 6-pos.
Reply With Quote Quick reply to this message Go to the top
Sponsored Links
Advertisement
 
  #2  
Old 06-10-2011, 10:45 PM
countryboyrob
Offline
PSN Veteran
Member's Gallery
 
Join Date: Nov 2007
Location: No man's land
Posts: 15,537
Re: 1997 F250 problem

Autozone scanners wont work on our trucks.
__________________
02 f250
Reply With Quote Quick reply to this message Go to the top
  #3  
Old 06-10-2011, 11:47 PM
ascrap2003's Avatar
ascrap2003
Offline
Famous words "Watch This"
Member's Gallery
 
Join Date: Feb 2011
Posts: 264
Re: 1997 F250 problem



Get a scan first

Also check icp sensor for oil, valve cover gasket connectors for oil/burnt/broken pins.

Could be simple or a combination of problems being your truck is old
I know from experience. Other possibles
include ipr sensor & or connector, faulty cps connector or wires, faulty/chaffed harness wiring.

But hopefully something simple that will show up with a scan
get with a good diesel shop or ford for a scan & have them run
a complete scan along with cct & buzz tests then go from there.

that is where I would start.
__________________
2002 F350 SuperCab SWR Lariat, Hutch Mod, EBPV Delete, Down Pipe,

My websites:
Non Ferrous Metals Recycling
X-ray film recycling
Aircraft Engine Buyers
Reply With Quote Quick reply to this message Go to the top
  #4  
Old 06-11-2011, 04:56 AM
Patrick Feeley's Avatar
Patrick Feeley
Offline
PSN Veteran
Member's Gallery
 
Join Date: Mar 2008
Location: Tehachapi, CA
Posts: 2,061
Re: 1997 F250 problem

Also, take a quick look and see if the "tin nut" on the IPR is loose or missing. Cheers!
__________________
97 F250 SC 4x4, E4OD, 4.10 LS, Basically Stock, Relocated Block Heater Plug, Ext Trans Filter, Tru-Cool Max, I/C Mounted but not Plumbed

SOLD: 94 F350 CC DRW PSD, 5 Speed, 4.10 LS, SBC Con-O, Baldwin Filter, Tymar HPX Hose, 3 DP, Bilsteins, $12 AIC, Coolant Filter, Explorer O/H Console, Trans Temp, Boost, and Pyro, Pedestal Mod, Gutted EBPV
Reply With Quote Quick reply to this message Go to the top
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




(View-All Members who have read this thread : 47
7.3psd97444, ascrap2003, aussie powerstroke, awehrmann, BIG E, Brian Cox, broodu, Bugman, cowboy_dan, cressman_cj, Darkhollow, Desert Rancher, dglenn1969, Dieseltron, DougN, dsinderson, farmer7.3, floridastroke, foxman, FreddieZ, Frenchb85, Goodbar419, Headcase98002, ibestrokin97, j.soffa, JCart, jmsmith76, josh1.123, Josh2021, kramarj, lgjttu, madpogue, Metzman, Patrick Feeley, powerstroke095, rancherstroker6, rashole, salprofish, swff14, TacticalMonk, The Oiler, The Struggler, toolmangary, winkfab, xrcris
Thread Tools
Display Modes


Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:29 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.