1996 7.3 low oil pressure and low on power - PowerStrokeNation : Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-19-2013, 11:46 PM Thread Starter
PSN Newb
Join Date: Jan 2012
Location: Hellertown, PA
Posts: 17
1996 7.3 low oil pressure and low on power

I just got my 7.3 on the road after a new trans and it has been running good but seems a little sluggish. And I know the injectors run off of oil pressure and the gauge on my dash is in the middle of the gauge but my dads runs at like 3/4 and seems to have a little more power. What I'm wondering if it's my oil pump on the crank? Or the hpop? Just did a oil change and filter. And also my fuel filter light will sometimes flash at idle. After long trips it seems but if I turn it off and back on it stays off? Any help would be appreciated. I know the motors just don't want to drop money in the wrong spot. Oh also it has a brand new fuel pump in
czangli7 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 01-19-2013, 11:48 PM
PSN Veteran
Join Date: Nov 2007
Location: No man's land
Posts: 15,554
Re: 1996 7.3 low oil pressure and low on power

Click thread tools click move thread click obs tech section
countryboyrob is offline  
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome