AC problems! Not blowing strong. - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 07-27-2012, 08:33 PM Thread Starter
HTFU
 
Evofit300's Avatar
 
Join Date: Jun 2012
Location: Blue, Springs, MO
Posts: 70
AC problems! Not blowing strong.

AC system won't blow strong enough to cool the cab down. I took it in to a local mechanic and had them do an AC check. Evaporated system, recharged (was 4 oz low), tested temps (was blowing around 50 degrees), and was told to check a TSB on the DATC. Bought another DATC and plugged it in and no change, so returned it. It's blowing the same out of both sides. Not coming out of the defrost or the floor when set to front vents (just as it is supposed to).

Not sure what else it can be. You can hear it blow harder as you turn the fan up, just blows the same on high as if it were on a medium setting.

Thanks in advance for help.

2008
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F250 CC SB SRW Lariat 4x4 6.4L
Ranch Hand Deer Tenderizer
S&B Cold Air Intake
Mini Maxx with DPF/EGR Delete
18" Weld Velociti with 35x12.50 Toyo Open Country MT
Evofit300 is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 07-28-2012, 05:20 PM Thread Starter
HTFU
 
Evofit300's Avatar
 
Join Date: Jun 2012
Location: Blue, Springs, MO
Posts: 70
Re: AC problems! Not blowing strong.

Have seen other problems with AC, but seems like this one isn't common. Need to figure out a direction to go next.

2008
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F250 CC SB SRW Lariat 4x4 6.4L
Ranch Hand Deer Tenderizer
S&B Cold Air Intake
Mini Maxx with DPF/EGR Delete
18" Weld Velociti with 35x12.50 Toyo Open Country MT
Evofit300 is offline  
post #3 of 10 (permalink) Old 07-30-2012, 05:50 PM
PSN Veteran
 
greaseltn's Avatar
 
Join Date: Sep 2009
Location: Hillsborough, NC
Posts: 750
Re: AC problems! Not blowing strong.

You may need to take the fan out and see if a mouse built a nest in the cage. I've seen it before, but usually on a truck that spends alot of time parked.
greaseltn is offline  
post #4 of 10 (permalink) Old 07-30-2012, 06:39 PM
TimmyaleX
 
Join Date: Aug 2009
Location: 5150 on 2 wheels
Posts: 656
Re: AC problems! Not blowing strong.

DATC?

Support Blue Collar Workers

-2008 F-350 XLCCLBSRWZF6
-Fast Idle Switch
-5" DP back
-Innovative livewire
-No Limit
-Newton Fat Boy Traction Bars
-Ebay Leveling Kit
-ICON adj. Trac BAr
-NITTO Terra Grapplers
-Flo Pro EGR delete
-South Bend 3250
-Spartan
-Lab Pit "Stella"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
HD-tech-NH is offline  
post #5 of 10 (permalink) Old 07-31-2012, 06:59 PM Thread Starter
HTFU
 
Evofit300's Avatar
 
Join Date: Jun 2012
Location: Blue, Springs, MO
Posts: 70
Re: AC problems! Not blowing strong.

Dual Automatic Temperature Control
It's the control unit that sits below the radio.

Have recently replaced the belts, tensioner, and idler pulleys, and haven't seen any creature nests. Even sprayed out the fins on the radiator.

2008
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F250 CC SB SRW Lariat 4x4 6.4L
Ranch Hand Deer Tenderizer
S&B Cold Air Intake
Mini Maxx with DPF/EGR Delete
18" Weld Velociti with 35x12.50 Toyo Open Country MT
Evofit300 is offline  
post #6 of 10 (permalink) Old 07-31-2012, 07:38 PM
PSN Local
 
wynndaddy's Avatar
 
Join Date: May 2008
Location: TN
Posts: 492
My work truck did this and it had sucked a plastic bag up from the floor and was blocking flow . It would try to change but couldn't complete the cycle . You could hear it blowing hard behind the dash .

1997 cc swb 4x4
.
wynndaddy is offline  
post #7 of 10 (permalink) Old 08-07-2012, 01:49 AM Thread Starter
HTFU
 
Evofit300's Avatar
 
Join Date: Jun 2012
Location: Blue, Springs, MO
Posts: 70
Re: AC problems! Not blowing strong.

I ran an inspection camera through the vents and found no obstructions .

I read that the evaporator is likely a cause in dusty areas. I bought the truck from Tennessee and there was alot of fine tan dirt in the air filter and all over the truck. So I'm assuming it would probably be beneficial to clean out the evaporator.

Here's the problem, I can't find any good instructors on how to get to it and open it up. Any help would be appreciated.

2008
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F250 CC SB SRW Lariat 4x4 6.4L
Ranch Hand Deer Tenderizer
S&B Cold Air Intake
Mini Maxx with DPF/EGR Delete
18" Weld Velociti with 35x12.50 Toyo Open Country MT
Evofit300 is offline  
post #8 of 10 (permalink) Old 06-17-2013, 02:06 PM
PSN Local
 
johnnyroastbeef's Avatar
 
Join Date: Feb 2011
Location: Montgomery County, PA
Posts: 232
Re: AC problems! Not blowing strong.

Quote:
Originally Posted by Evofit300 View Post
I ran an inspection camera through the vents and found no obstructions .

I read that the evaporator is likely a cause in dusty areas. I bought the truck from Tennessee and there was alot of fine tan dirt in the air filter and all over the truck. So I'm assuming it would probably be beneficial to clean out the evaporator.

Here's the problem, I can't find any good instructors on how to get to it and open it up. Any help would be appreciated.
did you ever figure out this issue? My AC seems to be in the same situation not blowing very hard. Just wondering if you ever fixed it and what you determined the cause to be. thanks.

-'09 F350 CCSB, SRW, 2.5" leveling kit, ICON adjustable track bar, Alradco Radiator, 35/12.5R20 Nitto Trail Grappler, Detroit TrueTrac
johnnyroastbeef is offline  
post #9 of 10 (permalink) Old 12-02-2014, 02:11 AM Thread Starter
HTFU
 
Evofit300's Avatar
 
Join Date: Jun 2012
Location: Blue, Springs, MO
Posts: 70
Re: AC problems! Not blowing strong.

Hopefully you have fixed the problem. I haven't been on in a while. For others looking for the resolve. My evaporator was dirty.

I removed the glove box and behind it is a large black box. To save myself the trouble, I cut about a 3"x3" square in it with a razor knife. I used a/c condenser cleaner (from home depot for home a/c units). I sprayed that inside and let it sit for a couple minutes. then with a spray bottle of water rinsed it all out. Make sure it drains out of the drain tube that sits behind the air filter box. If not, stick something in there to unclog it. I cut out a piece of aluminum to cover the whole, ran a bead of silicone around it, a screwed it on. Has held up for over a year with no problems.

2008
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
F250 CC SB SRW Lariat 4x4 6.4L
Ranch Hand Deer Tenderizer
S&B Cold Air Intake
Mini Maxx with DPF/EGR Delete
18" Weld Velociti with 35x12.50 Toyo Open Country MT
Evofit300 is offline  
post #10 of 10 (permalink) Old 08-18-2015, 07:13 PM
PSN Newb
 
Join Date: Aug 2015
Posts: 1
Re: AC problems! Not blowing strong.

Where did you cut the hole in the middle of to the right or left side?
Magta is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome