No Signal To The Glow Plug Relay - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 37 (permalink) Old 03-11-2012, 09:32 PM Thread Starter
PSN Local
 
Join Date: Jun 2009
Location: Lakeside California
Posts: 464
No Signal To The Glow Plug Relay

I searched for a while but can't find the answer.

I thought my glow plug relay went out so I replaced it. I used a test light and found that the one side that is always hot is hot. But the side that should get hot when I turn the key to the on position never gets hot. Like a dummy I did not bother to check anything else and bought a new relay. I figured it was old enough. But after putting in the new relay it still does the same thing.

So I got out my volt meter to check the small terminals on the relay and they never get any power to them. All of my fuses under the hood seem to be fine. Not sure exactly what fuse is in control of the relay.

In the morning I have to pop the hood and use a screwdriver or whatever to jump the relay. For the rest of the day it starts fine. Would be nice not to have to crawl around the truck in the morning.

1997 F350 with a few mods and over 392,000 miles.

National Spring Leafs, E-Fuel, John Woods Transmission, Detroit Lockers Front & Rear, 4:56 Gears, Michelin XML Tires, Custom RSK...

Lots of pictures
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lovesdunes is offline  
Sponsored Links
Advertisement
 
post #2 of 37 (permalink) Old 03-11-2012, 09:43 PM
PSN Local
 
excavator's Avatar
 
Join Date: Jan 2008
Posts: 235
Re: No Signal To The Glow Plug Relay

one small wire should get power when key is turned on. I would double check the fuses with ohm meter. The other small wire grounds the relay from a signal from PCM and then ungrounds it to turn glow plugs off

96 F250 XLT 4x4 210000 miles Dana 60, Baby Swamped,Tony Wildman tunes,AutoMeter Pyro Boost Trans ,DPP downpipe,Tymar intake BTS TRANS

e99 f350 cc/lb drw php hydra plus Tony Wildman tune


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
excavator is offline  
post #3 of 37 (permalink) Old 03-11-2012, 09:43 PM
PSN Veteran
 
ajfetterman's Avatar
 
Join Date: Nov 2011
Location: Clinton Ohio
Posts: 1,702
Re: No Signal To The Glow Plug Relay

I too would like to know what the fix is. I had the same issue and blamed it on the relays, I bought 4 before I figured it wasnt the relay. I ended up putting a switch inside the cab to ground out the relay for the PCM. I would like it to work correctly but that was a quick easy fix to get me through winter.

I was told it is either the wire from the PCM or the PCM isnt sending the signal (grounding out) with the key. I cant find any broken wires and Im not sure if a PCM reflash would fix it or a whole new PCM would be the fix.

2002 CCLB 4X4 6" skyjacker lift * Ford AIC * 4" turbo back Diamond Eye exhaust * 6637 mod w/ Donaldson filter * Gauges* No Foil * Edge Insight CTS
1988 Camaro Iroc Z
2000 Polaris Scrambler 4x2 400- Bored out and tuned by DAB Racing
~Andy~



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ajfetterman is offline  
post #4 of 37 (permalink) Old 03-11-2012, 09:49 PM
PSN Local
 
excavator's Avatar
 
Join Date: Jan 2008
Posts: 235
Re: No Signal To The Glow Plug Relay

Double check fuse 22 under hood
If relay is not getting grounded from PCM then the diode in PCM burnt out and if the small wire on relay is not getting power when key is on then double check fuse 22

96 F250 XLT 4x4 210000 miles Dana 60, Baby Swamped,Tony Wildman tunes,AutoMeter Pyro Boost Trans ,DPP downpipe,Tymar intake BTS TRANS

e99 f350 cc/lb drw php hydra plus Tony Wildman tune


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
excavator is offline  
post #5 of 37 (permalink) Old 03-11-2012, 09:51 PM
PSN Veteran
 
ajfetterman's Avatar
 
Join Date: Nov 2011
Location: Clinton Ohio
Posts: 1,702
Re: No Signal To The Glow Plug Relay

So if fuse 22 is good then the PCM needs replaced?

2002 CCLB 4X4 6" skyjacker lift * Ford AIC * 4" turbo back Diamond Eye exhaust * 6637 mod w/ Donaldson filter * Gauges* No Foil * Edge Insight CTS
1988 Camaro Iroc Z
2000 Polaris Scrambler 4x2 400- Bored out and tuned by DAB Racing
~Andy~



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ajfetterman is offline  
post #6 of 37 (permalink) Old 03-11-2012, 09:57 PM Thread Starter
PSN Local
 
Join Date: Jun 2009
Location: Lakeside California
Posts: 464
Re: No Signal To The Glow Plug Relay

Fuse 22 is the fuse that also controls the fuel heater in the bowl?

1997 F350 with a few mods and over 392,000 miles.

National Spring Leafs, E-Fuel, John Woods Transmission, Detroit Lockers Front & Rear, 4:56 Gears, Michelin XML Tires, Custom RSK...

Lots of pictures
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lovesdunes is offline  
post #7 of 37 (permalink) Old 03-11-2012, 09:59 PM
PSN Veteran
 
ajfetterman's Avatar
 
Join Date: Nov 2011
Location: Clinton Ohio
Posts: 1,702
Re: No Signal To The Glow Plug Relay

Quote:
Originally Posted by lovesdunes View Post
Fuse 22 is the fuse that also controls the fuel heater in the bowl?
I think you are right. Seems I have checked that fuse before and it was fine. So I might be down to a new PCM.

2002 CCLB 4X4 6" skyjacker lift * Ford AIC * 4" turbo back Diamond Eye exhaust * 6637 mod w/ Donaldson filter * Gauges* No Foil * Edge Insight CTS
1988 Camaro Iroc Z
2000 Polaris Scrambler 4x2 400- Bored out and tuned by DAB Racing
~Andy~



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ajfetterman is offline  
post #8 of 37 (permalink) Old 03-11-2012, 10:02 PM
PSN Local
 
excavator's Avatar
 
Join Date: Jan 2008
Posts: 235
Re: No Signal To The Glow Plug Relay

Double check fuse 22 for power and double check that one small wire on relay has power when key is on. If one small wire has power than the other small wire gets grounded from PCM unless PCM diode is burnt

If no power at all to one small wire fuse 22 is bad or bad wire

96 F250 XLT 4x4 210000 miles Dana 60, Baby Swamped,Tony Wildman tunes,AutoMeter Pyro Boost Trans ,DPP downpipe,Tymar intake BTS TRANS

e99 f350 cc/lb drw php hydra plus Tony Wildman tune


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
excavator is offline  
post #9 of 37 (permalink) Old 03-11-2012, 10:06 PM
PSN Veteran
 
ajfetterman's Avatar
 
Join Date: Nov 2011
Location: Clinton Ohio
Posts: 1,702
Re: No Signal To The Glow Plug Relay

Happen to know what the ohm reading should be? or does any reading mean it is ok? Like I said I think I need a PCM.

2002 CCLB 4X4 6" skyjacker lift * Ford AIC * 4" turbo back Diamond Eye exhaust * 6637 mod w/ Donaldson filter * Gauges* No Foil * Edge Insight CTS
1988 Camaro Iroc Z
2000 Polaris Scrambler 4x2 400- Bored out and tuned by DAB Racing
~Andy~



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
ajfetterman is offline  
post #10 of 37 (permalink) Old 03-11-2012, 10:11 PM Thread Starter
PSN Local
 
Join Date: Jun 2009
Location: Lakeside California
Posts: 464
Re: No Signal To The Glow Plug Relay

Fuse 22 is ok. My electric pump gets power from the old fuel heater.

No power to any of the small wires. I will try to check the wires and make sure there is nothing wrong between there and the PCM. If the wires are good then I guess it's PCM time.

I did have the PCM out not too long ago when I swapped out my split shot injectors to single shot. But everything was fine for a few months after I swapped all of that out.

Do both of those small wires go to the PCM?

1997 F350 with a few mods and over 392,000 miles.

National Spring Leafs, E-Fuel, John Woods Transmission, Detroit Lockers Front & Rear, 4:56 Gears, Michelin XML Tires, Custom RSK...

Lots of pictures
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
lovesdunes is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



  LinkBacks (?)
LinkBack to this Thread: http://www.powerstrokenation.com/forums/17-1994-1997-power-stroke-technical-info/127800-no-signal-glow-plug-relay.html
Posted By For Type Date
6.0 Powerstroke Glow Plug Diagram_Yaelp Search This thread Refback 11-13-2015 06:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome