Question about map sensor - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 10-29-2009, 02:56 AM Thread Starter
PSN Newb
 
Join Date: Oct 2009
Posts: 9
Question about map sensor

I have a 99.5 7.3L Powerstroke. For the past 2-3 weeks, I have been experiencing significant power loss and MPGs. I have regulated fuel return, DIY Tymar intake, muffler delete. I have replaced all the o-rings in the turbo, checked manifold connections, all ductwork connections. I have fresh oil, fresh fuel filters, so now I am thinking possible map sensor. I'm not quite sure how to test the map sensor. I put my volt meter test leads on the wires with the connector plugged in, I was getting 5 volts at an idle. This seems way too high, but I'm not sure. Any suggestions?
dadto4boys is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 10-29-2009, 02:59 AM
PSN Veteran
 
POWERSTROKER's Avatar
 
Join Date: Oct 2007
Location: Somerset, TX
Posts: 1,554
Re: Question about map sensor

Whats your fuel pressure?

Early 1999 (4/98) 7.3, Automatic, f-250 superduty, 4x4, crewcab, shortbed.

CCV Mod
knn intake
banks exhaust
banks power elbo
banks turbo housing
big head waste gate-disconnected
Tuning by
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

4 gauge pod with DiPricol pyro, boost, trans temp, HPOP

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
POWERSTROKER is offline  
post #3 of 10 (permalink) Old 10-30-2009, 12:12 AM Thread Starter
PSN Newb
 
Join Date: Oct 2009
Posts: 9
Re: Question about map sensor

65psi.
dadto4boys is offline  
post #4 of 10 (permalink) Old 10-30-2009, 06:45 PM
PSN Veteran
 
fbilly420's Avatar
 
Join Date: Sep 2007
Location: Utah
Posts: 1,830
Re: Question about map sensor

Do you have gauges? If so how much boost are you seeing? Do you see any soot around any of the exhaust connections before the turbo?

How are your brakes? If you have a brake or park brake hanging up that will really kill fuel mileage.

2001 F250, CCSB, 4X4, Auto, Forged rods
Lots of go fast parts and still slow.

2001 F250, STD cab, 2WD
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Frame is a little shorter now
workin on body
engine build underway


fbilly420 is offline  
post #5 of 10 (permalink) Old 10-30-2009, 06:59 PM Thread Starter
PSN Newb
 
Join Date: Oct 2009
Posts: 9
Re: Question about map sensor

ive checked for leaks evryware i can think of i need to get gauges i was also thinking about wastgate is there a way to check this with out gauges
this is my first diesel thanks for the help
dadto4boys is offline  
post #6 of 10 (permalink) Old 10-30-2009, 07:05 PM Thread Starter
PSN Newb
 
Join Date: Oct 2009
Posts: 9
Re: Question about map sensor

i have also checked brakes dont seem to be hanging up
dadto4boys is offline  
post #7 of 10 (permalink) Old 10-30-2009, 07:09 PM
owner/president
 
dixieland-diesels's Avatar
 
Join Date: Aug 2008
Location: HouseSprings/Ellsinore MO.
Posts: 2,768
Send a message via MSN to dixieland-diesels
Re: Question about map sensor

Quote:
Originally Posted by dadto4boys View Post
ive checked for leaks evryware i can think of i need to get gauges i was also thinking about wastgate is there a way to check this with out gauges
this is my first diesel thanks for the help
Unplug the redline and plug the redline and see if your boost #s change or if they just get there quicker.

03 lariat cc,4x4 7.3,DP-F5,36''MT,8"lift w/trac.bars,4"Silverline ss.exh,AFE II,Optimas,ATS housing,WW,Turbomaster,6.0 IC & tranny cooler,BTS,ISSPRO gauges,HPX,ITP RR,BRV+,Powerslots,WARN prem-hubs,coolant filter,ccv mod,08 mirrors,ARP's,mod.fuel & inj's.,Crower rods,AIH delete,AMSOIL fluids. ~waitn on the 38R~
dixieland-diesels is offline  
post #8 of 10 (permalink) Old 10-30-2009, 11:16 PM Thread Starter
PSN Newb
 
Join Date: Oct 2009
Posts: 9
Re: Question about map sensor

ok i went to the local parts store and got a boost gauge i tapped the manifold right below the map line the gauge read no boost even under throttle
unhooked and pluged wastgate line slill nothing i took the map line off and could feel some pressure but i had to put it right to my face before i could feel it
dadto4boys is offline  
post #9 of 10 (permalink) Old 10-31-2009, 10:00 AM
PSN Veteran
 
Join Date: Mar 2008
Posts: 529
Re: Question about map sensor

Were you actually driving the truck or sitting in nuetral at full throttle? If just sitting reving it up, you will not be able to acheive boost.

01' F250 PSD CC 4x4, GTP38R, Hi-Flow outlet, DI Bellowed up-pipes, BTS Hpop, DI Regulated return, ITP Annilator, AM 3pod, AFE PG7 Stage II, Silverline 4in T-Back, 6.0 Trans cooler, Dp F5, BTS Trans, True-Trac 3.73, Powerslot Cryo, Rotella ELC, Nitto Terra 285/75/16E on Alcoa wheels
Torque37 is offline  
post #10 of 10 (permalink) Old 10-31-2009, 03:49 PM Thread Starter
PSN Newb
 
Join Date: Oct 2009
Posts: 9
Re: Question about map sensor

I did put in in drive, and hold on the brakes and rev it up, but I did not drive down the road. I figured this would achieve a load on the engine. Tomorrow I am going to clean my EBPV tube and sensor, if this is clogged, could this cause no boost?
dadto4boys is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome