I hope the NATION is more responsive than .org - PowerStrokeNation : Ford Powerstroke Diesel Forum
 13Likes
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 92 (permalink) Old 03-25-2017, 11:32 AM Thread Starter
PSN Local
 
Join Date: Mar 2017
Posts: 51
Garage
I hope the NATION is more responsive than .org

I shared a problem I'm having on another forum and received no assistance so here I am in the NATION.

My problem is my truck loses power under acceleration and dies randomly. I had it scanned at Oreilly's and a shop and they both told me they couldn't communicate with my computer so I replaced the computer, no change in performance. Turns out neither of them knew how to scan a SuperDuty. I took it to another shop for a scan and they said I had multiple codes and I needed to leave it for diagnosis. They said it was most likely a CPS but it had codes for low fuel pressure too. I replaced the CPS and it got better but still had low power and dies randomly. Since then I have replaced my air filter, my fuel filter, tested my fuel pressure and adjusted to 60 psi, rebuilt the IPR and replaced the ICP. I sill lose power on acceleration and the truck still dies randomly. I downloaded FORSCAN and I see ICP numbers reach 1700 psi during acceleration and suddenly drop to 700 psi when it loses power. My IPR numbers are about 20% at idle and when the truck loses power the IPR numbers are about 65%. I changed my oil but that didn't change performance either. I took a resistance reading across the 2 terminals of the IPR and got a reading of 10 ohms. I don't think that's too bad. I expected somewhere around 2-5 ohms but I don't think 10 is unreasonable. When I rebuilt the IPR I could not unscrew the innards out of the IPR so I'm not 100% sure there isn't any gunk stuck in the spring however I did clean it as well as I could and it seemed to move freely when I pushed on the plunger. I have a new IPR on the way and if that doesn't fix my problem I think I'll have no choice but to replace my HPOP. Can anyone help? If you have an idea or any suggestions I would greatly appreciate hearing them. One last thing, I have already done the $.50 UVC harness mod on both sides. All of these problems started just before my TS6 chip arrived so I haven't even been able to enjoy what I expected was going to be a great improvement.

Sorry for the long read but I wanted to be a thorough as possible so there wouldn't be any guessing as to what I have or haven't done.

E99 F250 2WD CCLB
TS6
6637 Intake
High voltage IDM
4.7 Zener Diode Boost fooler
4" turbo back MBRP exhaust
3 in 1 Glowshift (on the way)
Less than 90K miles
Deanramey is offline  
Sponsored Links
Advertisement
 
post #2 of 92 (permalink) Old 03-25-2017, 11:35 AM Thread Starter
PSN Local
 
Join Date: Mar 2017
Posts: 51
Garage
Re: I hope the NATION is more responsive than .org

This is the last scan at idle after my last drive. The green is my ICP the blue is my IPR. Sorry for the orientation.
Attached Images
File Type: jpg 20170322_184027.jpg (19.6 KB, 36 views)

E99 F250 2WD CCLB
TS6
6637 Intake
High voltage IDM
4.7 Zener Diode Boost fooler
4" turbo back MBRP exhaust
3 in 1 Glowshift (on the way)
Less than 90K miles
Deanramey is offline  
post #3 of 92 (permalink) Old 03-25-2017, 11:40 AM Thread Starter
PSN Local
 
Join Date: Mar 2017
Posts: 51
Garage
Re: I hope the NATION is more responsive than .org

I suppose I should have also mentioned that the sensors I replaced, I put in Ford sensors.

E99 F250 2WD CCLB
TS6
6637 Intake
High voltage IDM
4.7 Zener Diode Boost fooler
4" turbo back MBRP exhaust
3 in 1 Glowshift (on the way)
Less than 90K miles
Deanramey is offline  
 
post #4 of 92 (permalink) Old 03-25-2017, 11:43 AM
alleged moderator
 
tjctransport's Avatar
 
Join Date: Jul 2009
Location: in a loony bin in N.J.
Posts: 3,740
Re: I hope the NATION is more responsive than .org

welcome to PSN. have you checked all the ground connections??
i have found most of the time strange running/stalling issues are usually caused by bad ground connections.

tom
owner of almost to many fords.



If you want the moral high ground, make sure you're not standing on a hill of horsecrap.
tjctransport is offline  
post #5 of 92 (permalink) Old 03-25-2017, 11:51 AM Thread Starter
PSN Local
 
Join Date: Mar 2017
Posts: 51
Garage
Re: I hope the NATION is more responsive than .org

Every ground I've seen looks and is secure but is there someplace specific I should be looking?

E99 F250 2WD CCLB
TS6
6637 Intake
High voltage IDM
4.7 Zener Diode Boost fooler
4" turbo back MBRP exhaust
3 in 1 Glowshift (on the way)
Less than 90K miles
Deanramey is offline  
post #6 of 92 (permalink) Old 03-25-2017, 12:06 PM
Moderator
 
Sbluke55's Avatar
 
Join Date: Jun 2015
Location: Colorado
Posts: 4,141
Re: I hope the NATION is more responsive than .org

Sounds like you have a hpo leak somewhere. Most likely injector o rings. Your ipr should be nowhere near 20% at idle. Was the fuel filter black? You could pull the valve covers and start the truck and look at the injectors while running. If you see oil bubbling up around the base of the injector. That one has bad orings. Also watch each injector and see if it is discharging about the same amount of oil out of the spill ports.
Zmann likes this.

01 f-250, Standard
Rev tech 4" lift, 37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks intercooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
Sbluke55 is offline  
post #7 of 92 (permalink) Old 03-25-2017, 12:13 PM Thread Starter
PSN Local
 
Join Date: Mar 2017
Posts: 51
Garage
Re: I hope the NATION is more responsive than .org

Yes the fuel filter was black and I've read that could be due to a leaking injector o-ring. I've also read that a black fuel filter is very common even without a leaking injector o-ring. The fuel in the bowl is clear and the fuel I took out of the pressure gauge line was also clear. Thank you for the suggestion to watch the injectors while running. I have to work today but the first chance I get I'll take the valve covers off and watch it run. I'll let y'all know what I see then. Thanks again. Dean

E99 F250 2WD CCLB
TS6
6637 Intake
High voltage IDM
4.7 Zener Diode Boost fooler
4" turbo back MBRP exhaust
3 in 1 Glowshift (on the way)
Less than 90K miles
Deanramey is offline  
post #8 of 92 (permalink) Old 03-25-2017, 12:44 PM
Moderator
 
Sbluke55's Avatar
 
Join Date: Jun 2015
Location: Colorado
Posts: 4,141
Re: I hope the NATION is more responsive than .org

If you find one bad oring. It's best to do all 8 injectors. It's only $65.

01 f-250, Standard
Rev tech 4" lift, 37" military wrangler Mt tires
KC diy 66, Full force 160/100 and custom tunes from PHP
Banks intercooler and full 4" exhaust, Diy S&B intake
Diy quad feed, Hydra, Isspro boost, pyro, and fuel pressure
3/0 battery cables with military style terminals
Sbluke55 is offline  
post #9 of 92 (permalink) Old 03-25-2017, 01:11 PM
PSN Veteran
 
Bugman's Avatar
 
Join Date: Aug 2007
Location: Gypsum, Co
Posts: 3,212
Re: I hope the NATION is more responsive than .org

On the scan, Oreilly's quite possibly can't read any codes on these trucks. That is unless they have a code reader that can read Fords codes and 99% of the parts stores out there don't have one.

96 F250 XLT 4x4, 4:10 gears, 5 speed, Tymar intake and HX hose, downpipe, pyro and boost guages, coolant filter, Luc clutch
Bugman is offline  
post #10 of 92 (permalink) Old 03-25-2017, 01:42 PM
PSN Veteran
 
410customs's Avatar
 
Join Date: Aug 2016
Posts: 1,578
Re: I hope the NATION is more responsive than .org

correct. Also if they cannot connect (communicate) with PCM then you do not just go buy a new PCM, first you check the fuses the OBD port must have power for a scanner to communicate
I hope you saved your old PCM
Let these guys know what you see under the valve cover!

1997 CCFB 7.3, ZF5, 4x4, 4.10, baby swamps, TS6, RSK
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2001 Excursion 7.3, auto, 4x4, 3.73, freight train family hauler, collecting parts for suspension lift
2000 E350 7.3, auto 2wd, 3.73, toy hauler camper conversion...researching 4x conversion
SEVEN POINT THREE LEAKER
410customs is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome