need some help with 2003 7.3 - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-17-2017, 06:57 PM Thread Starter
PSN Newb
 
Join Date: Feb 2017
Posts: 2
need some help with 2003 7.3

Ok so I have read several posts and I am helping my buddy fix his 2003 powerstroke 7.3. In the past we had the pcm fail so we had replaced that and all was good, now he had it die on him when idling at his house. I went there and plugged into it with my torque pro app, I didn't see any signal from the icp sensor (0 psi showing while cranking) so we unplugged it and tried to crank however the batteries were low. I advised him to recharge them as we were under 9 volts with cranking. (he had put screw post terminal batteries in and was using a nut to hold them down) I advised getting the proper post terminals and then retry cranking the truck over once the batteries were charged. I went back that night and tried it, we got it fire for a second then it died again. I have verified that the idm is getting 11 volts while cranking by backprobing with my multimeter. I hooked up my torque pro app again and here is what I am monitoring:
Injector pulse width, icp pressure, ipr sensor, v batt, and volts ad as well as rpm. I also just added injector timing before top dead center
So we didn't get it to fire. With the key on I have 14.7 ipr and goes up while cranking, we got around 500 rpm on the first round of 20 seconds cranking. Injector pulse width was ranging from 3200 ish pico seconds and up. We have fuel in the bowl and I checked all fuses and unplugged the bowl heater just in case. So I want to know if there is anything else I should be monitoring to get the truck to fire up or do I just need to get more
crank time on it to prime the fuel system. I can't see oil pressure on my torque all but the oil level is good but I haven't pulled the plug on the oil reservoir by the top of the engine to check that level just yet.
Newfiedan is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 02-17-2017, 06:58 PM Thread Starter
PSN Newb
 
Join Date: Feb 2017
Posts: 2
Re: need some help with 2003 7.3

edit we are still waiting for the new icp sensor to come in and install it.
Newfiedan is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome