7.3L turbo engine loses power/RPM's - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 02-16-2009, 04:48 PM Thread Starter
PSN Newb
 
Join Date: Feb 2009
Posts: 2
Question 7.3L turbo engine loses power/RPM's

When holding at steady RPM's either driving or running in park (doesnt matter) it sounds like the engine is releasing air. When it does the engine loses power and the rpm's fall. If I accelerate it goes away until the rpm's hold steady again. Any ideas? ? ? ?
99 SuperDuty is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 02-16-2009, 04:57 PM
OBS PSD Owner
 
Join Date: Dec 2008
Posts: 10
Re: 7.3L turbo engine loses power/RPM's

My 96 Powerstroke has the same problem, at lower RPMs (1500 range)when motor is cold, while holding the same throttle position. Push harder and it will speed up and be fine. Can hear the same air sucking noise. Any Suggestions?
7.3fordman is offline  
post #3 of 8 (permalink) Old 02-16-2009, 05:07 PM
PSN Veteran
 
casper7.3's Avatar
 
Join Date: Sep 2008
Location: Virginia
Posts: 853
Re: 7.3L turbo engine loses power/RPM's

only when cold i'd say the ebp valve is closing in wich case it would be a normal condition


on edit: welome to the nation guys

LUKE

2002 CCLB AUT0 4X4

S&B, DI/PRICOL GAUGES, CCV, ZOODAD, TS CHIP-MATT AT GEARHEAD,
38R, ADRENALINE, SWAMP'S IDM, 4" T/B MBRP
05 CONVERSION, 4 INCH LIFT, 325/65-18 FIERCE ATTITUDE M/T
WILSON 5000 GALAXY DX66

casper7.3 is offline  
post #4 of 8 (permalink) Old 02-16-2009, 05:08 PM
Lurker...
 
Fever's Avatar
 
Join Date: Aug 2007
Location: Hutchinson Minnesota
Posts: 553
Re: 7.3L turbo engine loses power/RPM's

EBPV sounds about right...

2003 F-350 Super Duty
Fever is offline  
post #5 of 8 (permalink) Old 02-16-2009, 05:26 PM
OBS PSD Owner
 
Join Date: Dec 2008
Posts: 10
Re: 7.3L turbo engine loses power/RPM's

Where is the EBPV located and should anything be done to fix this annoying problem?
7.3fordman is offline  
post #6 of 8 (permalink) Old 02-16-2009, 05:34 PM Thread Starter
PSN Newb
 
Join Date: Feb 2009
Posts: 2
Re: 7.3L turbo engine loses power/RPM's

my 99 doesnt do it cold. It will do it all the time. It is very annoying. It seems to be stealing power form the truck.
99 SuperDuty is offline  
post #7 of 8 (permalink) Old 02-27-2009, 01:25 AM
OBS PSD Owner
 
Join Date: Dec 2008
Posts: 10
Re: 7.3L turbo engine loses power/RPM's

Is it a possibility that it could be the wastegate??? Someone heard my truck and said that was what it sounded like
7.3fordman is offline  
post #8 of 8 (permalink) Old 02-27-2009, 02:22 AM
Harl
 
Harl's Avatar
 
Join Date: Nov 2008
Location: Harrison County, Indiana
Posts: 705
Send a message via AIM to Harl
Re: 7.3L turbo engine loses power/RPM's

Yep its the EBPV... My 96 did the same thing when I drive it took the power from my truck so I just unlpuged it..

Cody,17
DD-1996 F250 Powerstroke, 5speed, 4x4 ecsb

Mods: GlowShift Gauges-Boost, Pryo, Oil psi and Fuel psi. DIY 6637 Intake, 160/100's, Wildman 6pos, Stage 2 water/meth, D66, TE HPOP, Vailer Clutch, Custom Bars and 5in turbo back....

PT-1995 F350- totaled
Soon to be brought back to a 1992

http://www.youtube.com/truerednecks
Harl is offline  
Reply
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome