7.3 injector problem or bad fuel?? - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-01-2008, 12:41 PM Thread Starter
PSN Local
 
crazycruz257's Avatar
 
Join Date: May 2008
Location: Rockford, IL.
Posts: 256
7.3 injector problem or bad fuel??

O.K. I have a 2000 Ford rollback tow truck with a 7.3 Powerstroke. I just replace the injectors about a month ago and the truck was running sweet. I fueled up thursday night out of town. Come friday the truck had a very strong fuel smell when running. By friday night 1/2 to 3/4 of a tank of fuel later the truck was smoking real bad and sounded like it was missing at idle. On the highway it runs like a top. Shut the truck off for a few minutes and it has a catch when you turn it over. Like the injector is stuck open and dripping fuel in the cylinder. We put it on the scanner and it says the #8 injector is bad. Now my questions are: Did I get some bad fuel and clog the injector to where it is stuck open? Or Do I maybe have a defective injector that is shorted and staying open? And how could I tell? If it is clogged and stuck open is there a way to clean it? Thanks in advance.

Later Cruz
crazycruz257 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-01-2008, 12:46 PM
All done now
 
Arisley's Avatar
 
Join Date: Sep 2007
Location: Arlington, TX
Posts: 22,486
Re: 7.3 injector problem or bad fuel??

Welcome to the Nation!

Not real up on injectors, others are and will be on shortly.

I think I would start by pulling the injector and looking at o rings.

Early '99 F350 DRW, Excab, LB. Auto. 2WD, 2010 bed, 2005 headlights, 298K, on my way to 1000K.
H2E, 238 Hybrids, Adrenaline oil, Tuned by Tony. DIY Regulated Return.
Arisley is offline  
post #3 of 5 (permalink) Old 11-02-2008, 02:38 AM
What else?
 
smokyred's Avatar
 
Join Date: Dec 2007
Location: Wellington, OH
Posts: 4,156
Send a message via AIM to smokyred
Re: 7.3 injector problem or bad fuel??

#8 is driver's side-rear, check the wiring and if it's OK, pull the injector out and see if the o-rings are OK. If they are good you may have an internal injector problem.

Dave

'08 F250 6.4/Torqshift Spartan 310EL, Flo-Pro 4", White_monster air intake, RCD 4-link, RS9000's 584/1330
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Taking a break from trucks to play with guns!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
smokyred is offline  
post #4 of 5 (permalink) Old 11-02-2008, 03:47 AM
PSN Veteran
 
POWERSTROKER's Avatar
 
Join Date: Oct 2007
Location: Somerset, TX
Posts: 1,554
Re: 7.3 injector problem or bad fuel??

Swap #8 with 2,4, or 6, if the problem stays at #8 you have a wiring issue, if the problem follows #8 injector replace it.

Early 1999 (4/98) 7.3, Automatic, f-250 superduty, 4x4, crewcab, shortbed.

CCV Mod
knn intake
banks exhaust
banks power elbo
banks turbo housing
big head waste gate-disconnected
Tuning by
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

4 gauge pod with DiPricol pyro, boost, trans temp, HPOP

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
POWERSTROKER is offline  
post #5 of 5 (permalink) Old 11-04-2008, 02:32 AM
What else?
 
smokyred's Avatar
 
Join Date: Dec 2007
Location: Wellington, OH
Posts: 4,156
Send a message via AIM to smokyred
Re: 7.3 injector problem or bad fuel??

I should have said that, lol. Also after you find and fix the problem, replace the o-rings on the injectors you pulled out, they are not generally re-usable.

Dave

'08 F250 6.4/Torqshift Spartan 310EL, Flo-Pro 4", White_monster air intake, RCD 4-link, RS9000's 584/1330
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Taking a break from trucks to play with guns!


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
smokyred is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome