7.3 sudden problem - PowerStrokeNation : Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 25 (permalink) Old 04-24-2011, 08:09 PM Thread Starter
PSN Newb
Join Date: Dec 2010
Posts: 7
7.3 sudden problem

I have a 03 250 7.3 When I went to start the ole truck this am ,started just fine like it always does then all the sudden it starts running real ruff like its not running on all cylinders,cab shaking plus the cel comes on ....no smoke at all.

If I let it run a little wile it will even out for a few seconds then it ill go back to runny like crap again.Weird thing is its been running just fine,pulled the boat with it yesterday and not even a hiccup.

Can you guys give me a idea of where to start to look,would appreciate it ?

Best I can think must be some kind of sensor....duhh thats the best I can do.Did have the cps replaced when the recall came out and the alternator replaced last yr. .
Forgot to mention its all stock.

Power Stroke Ford F-250 2003 Ext,Cab.Stock
pwrstrdude is offline  
Sponsored Links
post #2 of 25 (permalink) Old 04-24-2011, 08:12 PM
<----Nice headlights!!!
TylerDurden's Avatar
Join Date: Apr 2010
Location: LaMoille,Illinois
Posts: 1,868
Re: 7.3 sudden problem

CPS again. Or hpo problems.

Check fuses first. Check connections second. Get a scanner third if there is a cel.

2000 F250 4x4 cc/sb. 6" w/37's and some other stuff.
TylerDurden is offline  
post #3 of 25 (permalink) Old 04-25-2011, 02:14 AM
All done now
Arisley's Avatar
Join Date: Sep 2007
Location: Arlington, TX
Posts: 22,486
Re: 7.3 sudden problem

I am guessing UVCH.

Early '99 F350 DRW, Excab, LB. Auto. 2WD, 2010 bed, 2005 headlights, 298K, on my way to 1000K.
H2E, 238 Hybrids, Adrenaline oil, Tuned by Tony. DIY Regulated Return.
Arisley is offline  
post #4 of 25 (permalink) Old 04-25-2011, 03:15 AM
OBS finding my way
jake2far's Avatar
Join Date: Oct 2010
Posts: 201
Re: 7.3 sudden problem

Originally Posted by pwrstrdude View Post
cab shaking plus the cel comes on ....no smoke at all.

Get the code, it will help with the diagnosis.


1996 OBS Crewcab, Shortbed, 4x4, Automatic Transmission, Baby Swamps, Adrenaline HPOP, SuperDuty Electric Fuel Pump conversion, Quick Turbo Housing, 6 Position Chip, 3" Down Pipe, 2 Disc Locking Converter, Intercooler
jake2far is offline  
post #5 of 25 (permalink) Old 04-25-2011, 03:47 AM
PSN Local
Marc's Avatar
Join Date: Jul 2007
Posts: 162
Re: 7.3 sudden problem

Originally Posted by Arisley View Post
I am guessing UVCH.
I second this, i would be pulling the valve covers to check the harnesses. A scanner to get the code/do a buzz test would also be nice.

The other thing ive seen with trucks is that because of neglected mainanence, oil leaks, or burning oil, if the oil level gets right down to the pickup tube so it draws some air by it too (about 6 quarts low) they will draw air and the oil will foam. As the oil warms and the level raises just a little tiny bit, it wont draw the air anymore and they will clear up.

NHRDA Region 2 Race Director
Marc is offline  
post #6 of 25 (permalink) Old 04-25-2011, 04:54 AM
PSN Veteran
tbolt's Avatar
Join Date: Nov 2008
Location: Peoria, Az
Posts: 3,939
Re: 7.3 sudden problem

UVCH is my bet. Been there.

early99 f350 cc, lb, 2wd, drw, A pillar autometer guages, CTS monitor, AIS intake, 4" turbo back cat delete diamondeye exhaust, dptuner, pmt1, jw vb, Swamps ab inj, Adrenaline oil, Coolingmist, 180*T, Trucool cooler, spin on trans filter, Firestone air bags, 2" frt leveling kit, now chased by a 34' toyhauler
tbolt is offline  
post #7 of 25 (permalink) Old 04-25-2011, 05:28 PM
OBS Addict
7.3psd97444's Avatar
Join Date: Mar 2011
Location: Blairsville PA
Posts: 1,538
Re: 7.3 sudden problem


Hope ya get it figured out.

97 SCLB 7.3 Handshaker
Valair Clutch, only the best.
TS 6 Position Tyrant Tuning
S&B, MBRP, Isspro, Mag-Hytec, 1.00 A/R Exhaust housing, HPX
Full sound system: Kicker-Kenwood
Dick Cepek DC-2's/Duratracs
On-Board Air
Few cosmetics
PSA # 269
7.3psd97444 is offline  
post #8 of 25 (permalink) Old 04-25-2011, 05:49 PM
PSN Newb
JesseM's Avatar
Join Date: Jan 2011
Posts: 26
Re: 7.3 sudden problem

If it comes back with the IDM code, check the wires OVER the valve cover too. My truck did this once to me over the winter, then went away. Then not until just last week and wouldnt go away. I was thinking the wires under the valvecover too like most guys say, but it turned out the harness OVER the valve cover was sagging and chafing and shorting out. As soon as I picked up the wires, problem solved.

"New" Diesel owner, have wanted one since I was about 10 yrs old. 2000 F-350, EC/SB, Lariat, DynoMax pipes, AEM intake, Banks Big Head, DiabloSport tuned for now ..List of things to buy: Wicked Wheel, Valve Body, 6.0 Intercooler and Tranny cooler, undecided on tuner...
JesseM is offline  
post #9 of 25 (permalink) Old 04-26-2011, 02:23 AM Thread Starter
PSN Newb
Join Date: Dec 2010
Posts: 7
Re: 7.3 sudden problem

Hey... Thanks for all the info.I dropped the truck off today to get a diagnostic done.I will post when I get the results tomorrow .

On thing I forgot to mention, I was getting cel (battery) off and on 2 weeks early and then it went away to never return.I checked the batteries that are 3 weeks old,the alt is new too.

Anyway ,what may I ask is a UVCH ? It sounds expensive

Power Stroke Ford F-250 2003 Ext,Cab.Stock
pwrstrdude is offline  
post #10 of 25 (permalink) Old 04-26-2011, 02:30 AM
Super Hauler!
Super_Hauler's Avatar
Join Date: Nov 2008
Location: Ft. Collins, CO
Posts: 3,881
Re: 7.3 sudden problem

under valve cover harness, your idm send a signal to your injectors and glow plugs through these. Usually they just melt or the clip breaks or loosens up and you get a bad connection. could have saved your self some money and did it yourself, its stupid easy! My little girl almost has it down.

MINE:08 F-250 CCSB king ranch erics tunes livewire
99: sclb 6 speed, 4" lift,4" exhaust, EB
99 F-450: ccfb Boss v plow. 6 speed 5" ex,EB
1985 Peterbilt 359 Big cam III Tuned up a little
HERS:2001 F-350 ccsb notta stock!
Originally Posted by prheitz View Post
I change my HPOP oil, the oil does circulate with the regular oil, it doesn't cycle as often and does get dirty sooner.
Super_Hauler is offline  
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply

Register Now

In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome