Installed new turbo. Truck now dies while driving. - PowerStrokeNation : Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 02-09-2017, 03:34 AM Thread Starter
PSN Newb
 
Join Date: Feb 2017
Posts: 5
Garage
Installed new turbo. Truck now dies while driving.

This is my first post so Please let me know if I'm in the wrong place! So my 2006 f250 6.0 turbos went out on me about 2 months ago. After letting the truck sit I finally bought a power max garret turbo (used not brand new but worked fine). After installing the turbo myself my truck at first started up and ran good but it didn't produce the amount of boost I expected. I let it sit the night and the next evening after work I came home and started the truck. Started fine besides it having to crank a little longer than usual but as I drove it I noticed it barely made any boost at all then it died on me while driving. I got it to start again after many tries and having to hold down the gas pedal to get it going. I continued you drive some and it did this again and again every couple minutes. It's also leaking oil from somewhere on the turbo. I honestly put the turbo on in a rush. Do you guys think I just didn't tightened down something correctly and that's causing the Low boost, dying, and oil leak?
Graveytrain1994 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 02-09-2017, 03:45 AM
PSN Local
 
Ruben72's Avatar
 
Join Date: Oct 2016
Posts: 89
Garage
Re: Installed new turbo. Truck now dies while driving.

Look the turbo supply line and drain tube

Sent from my XT1650 using Tapatalk


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Ruben72 is offline  
post #3 of 9 (permalink) Old 02-09-2017, 03:49 AM
Trust me, I got this...
 
Cummins Junkie's Avatar
 
Join Date: Apr 2016
Location: Murica
Posts: 286
Garage
Re: Installed new turbo. Truck now dies while driving.

Welcome! To answer your question, if you rushed and inadvertently did a shoddy job on the install, you should probably go back and inspect it very carefully, probably even take it back out and check for damage and look at the seal on the top of the turbo, and the tube leading out of it on the underside. Do that, and then report your results. Hope this helps!

Shoulda bought a Cummins.

1997 7.3L, 4x4, ZF-5, 305k, TS chip, 6637 filter, 4" straight piped duals...


Currently on lookout for axles for 05 swap and superduty seats
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Cummins Junkie is offline  
 
post #4 of 9 (permalink) Old 02-09-2017, 04:11 AM
Master BS'er
 
jamiesaun's Avatar
 
Join Date: Nov 2016
Location: Boise Idaho
Posts: 630
Re: Installed new turbo. Truck now dies while driving.

Make sure the turbo is in good shape. Impeller should be tight radially and axially. Check for leaks at the up pipe and compressor side. Leak is either at the feed tube and drain tube. Also make sure the solenoid is working.

Jamie.

p.s...I'm pretty frickin awesome!
jamiesaun is offline  
post #5 of 9 (permalink) Old 02-09-2017, 12:15 PM Thread Starter
PSN Newb
 
Join Date: Feb 2017
Posts: 5
Garage
Re: Installed new turbo. Truck now dies while driving.

Thanks for the advice! I know I had a really hard time with the tube on the underside getting it to sit in place. And the line coming out of the top seemed to be ozzing a little bit of oil but I tightened it down more it didn't seem to leaking that much. But under my turbo there is definitely a decent amount of oil
Graveytrain1994 is offline  
post #6 of 9 (permalink) Old 02-09-2017, 12:15 PM Thread Starter
PSN Newb
 
Join Date: Feb 2017
Posts: 5
Garage
Re: Installed new turbo. Truck now dies while driving.

I will break back into it and report back
Graveytrain1994 is offline  
post #7 of 9 (permalink) Old 02-11-2017, 04:51 PM Thread Starter
PSN Newb
 
Join Date: Feb 2017
Posts: 5
Garage
Re: Installed new turbo. Truck now dies while driving.

I've checked my oil drain tube and and the oil line on top of the turbo is all good. The truck will start up and run but when I put it in drive and try to go the turbo will just start cutting out then the truck dies.
Graveytrain1994 is offline  
post #8 of 9 (permalink) Old 02-11-2017, 07:20 PM Thread Starter
PSN Newb
 
Join Date: Feb 2017
Posts: 5
Garage
Re: Installed new turbo. Truck now dies while driving.

Truck is having a really hard time starting now
Graveytrain1994 is offline  
post #9 of 9 (permalink) Old 02-17-2017, 02:22 AM
Big dumb redneck
 
6speedSD's Avatar
 
Join Date: Apr 2009
Location: Olive Branch, Mississippi
Posts: 3,064
Garage
Re: Installed new turbo. Truck now dies while driving.

Turbo issues won't make a truck not crank or run. Need a way to monitor the ole girl. We need to see some data. Being a 06, I'm going to guess a high pressure leak....possibly STC fitting or standpipes.

2005 F350 CCLB Dually
Studded, deleted
5" straight piped
155/30's
KC Stage 1.5
Reg return
Beans sump to the stock pump
BPD FICM
Tuned by several...depends on my mood for the day.
6speedSD is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome