After EGR, Low Boost? - PowerStrokeNation : Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 18 (permalink) Old 12-04-2011, 12:21 AM Thread Starter
Bandwagon Jumper
 
19_A_LT's Avatar
 
Join Date: Jun 2009
Location: Canelo, AZ
Posts: 293
After EGR, Low Boost?

Got my truck back from my shop after doing my full EGR delete and it seems like it is running lower boost and missing a few horses than before. Is this normal? They rechecked all the boots and clamps. The EGR is still in and plugged in, but the uppipe was changed and cooler deleted? No codes/lights. What else could cause this?

1999 Dodge 2500 ECLB 24V Cummins, 2wd AT, 115k miles. 4" Straight, AFE Dry Filter *For Sale*
19_A_LT is offline  
Sponsored Links
Advertisement
 
post #2 of 18 (permalink) Old 12-04-2011, 06:11 PM
Super Duty Mod
 
Zmann's Avatar
 
Join Date: Nov 2010
Posts: 11,565
Re: After EGR, Low Boost?

? check the VGT connector on the turbo but I would think youd code for low boost?

O6 King Ranch cc sb 8 inch lift ,37 Toyo's,Helo’s Edge Insight CTS guage only , Auber EGT , o8 center console , xm satellite ,coolant filter,RSX 9000 shocks,dual TGC dual steering stabilizers ,Viper , remote toolbox popper, High Idle mod , $ link Rize , ARP's, BPD EGR cooler, Fabtech traction bars, Tony's tune
Zmann is offline  
post #3 of 18 (permalink) Old 12-06-2011, 09:16 AM Thread Starter
Bandwagon Jumper
 
19_A_LT's Avatar
 
Join Date: Jun 2009
Location: Canelo, AZ
Posts: 293
Re: After EGR, Low Boost?

The connector is good and working. The shop even repaired part of the wiring harness going to it. Before the EGR delete, it would make upwards and sometimes over 20psi boost. Now i can hardly get it over 10 pounds when i put the skinny pedal down. My 03 did the same sorta, but i blamed it on not putting the new uppipe in. I am stumped on this new one though.

1999 Dodge 2500 ECLB 24V Cummins, 2wd AT, 115k miles. 4" Straight, AFE Dry Filter *For Sale*
19_A_LT is offline  
post #4 of 18 (permalink) Old 12-07-2011, 06:32 PM
PSN Local
 
mcdaniel1991's Avatar
 
Join Date: Jul 2011
Location: Grafenwoehr, Germany
Posts: 127
Re: After EGR, Low Boost?

what brand Delete did you use? i just finished deleting my 06 and i used sinisters kit it was a pain in the A@# but i think im getting higher boost then before!?

2006 F-250 XLT FX4 PSD 180,000 Mi
Leveled, Innovative and Gearhead tunes, BPD 58v 6 Phase FICM, Straight exhaust, Sinister EGR/COOLER delete, Sinister Coolant Filter, Mobile 1 5w 30, Zoodad
mcdaniel1991 is offline  
post #5 of 18 (permalink) Old 12-13-2011, 01:41 AM Thread Starter
Bandwagon Jumper
 
19_A_LT's Avatar
 
Join Date: Jun 2009
Location: Canelo, AZ
Posts: 293
Re: After EGR, Low Boost?

I used custom diesels kit. It has the block off plate as well as the uppipe.. Is it common for the Turbos to gum up while performing deletes?

1999 Dodge 2500 ECLB 24V Cummins, 2wd AT, 115k miles. 4" Straight, AFE Dry Filter *For Sale*
19_A_LT is offline  
post #6 of 18 (permalink) Old 12-13-2011, 01:49 AM
Gambled and Lost 6.oh
 
ksieckmann's Avatar
 
Join Date: Aug 2011
Location: Midwest - where we love the USA
Posts: 927
Re: After EGR, Low Boost?

If your only getting 10psi surely you would get a low boost cel

'05 CCSB FX4
Deleted, Studded, SCT w/ Vivian's Looney Wild, Warrens 190cc. DieselRX

Performance-Fueling.com
ksieckmann is offline  
post #7 of 18 (permalink) Old 12-13-2011, 01:53 AM
Hood Rich
 
CTC DEEZUL's Avatar
 
Join Date: Sep 2010
Location: NW Indiana
Posts: 2,873
Send a message via AIM to CTC DEEZUL
Re: After EGR, Low Boost?

recheck y pipe connection at turbo...

NWI Coal Rollers Association

Local 444- Rolling Coal Teamsters
via Beans Toonz
DI SS Up-Pipe
GTP38R
CTC DEEZUL is offline  
post #8 of 18 (permalink) Old 12-13-2011, 02:53 AM
PSN Newb
 
Join Date: Dec 2009
Location: Michigan
Posts: 34
Re: After EGR, Low Boost?

20 PSI prior to the delete still seems a little on the low side to me. I am not tuned and will see 29 to 30 PSI at WOT.

2003 Super Duty 6.0L 4x4 SC/SB. Coolant filter, exhaust, gauges, CTS with some other stuff

Pulling a 35' KZ Sportster toy hauler
08 KTM450XCW-R
2000 CR500AF
1990 CR500
maps is offline  
post #9 of 18 (permalink) Old 12-13-2011, 06:34 AM
matt
 
mgeistman's Avatar
 
Join Date: Nov 2011
Location: victoria texas
Posts: 911
Re: After EGR, Low Boost?


4'' exhaust, egr delete, upgraded oil cooler, arp studs,50mm BOV, volant CAI, 66/73/.91 turbo, 205/100 injectors, crossover fuel line, airdog II, sct by TSD & ID, high idle mod, nitrous express with .092 jet, 26 GPH water/meth, ats stage 3 tranny, king Ranch front and rear captins chairs, and of course kicker sound system
mgeistman is offline  
post #10 of 18 (permalink) Old 12-13-2011, 11:24 AM Thread Starter
Bandwagon Jumper
 
19_A_LT's Avatar
 
Join Date: Jun 2009
Location: Canelo, AZ
Posts: 293
Re: After EGR, Low Boost?

I don't hit WOT very often; I baby the hell outta it. I know it definately is a dog after the EGR Delete. I also threw a Low Boost Code.

1999 Dodge 2500 ECLB 24V Cummins, 2wd AT, 115k miles. 4" Straight, AFE Dry Filter *For Sale*
19_A_LT is offline  
Reply
Gear in this thread - Powered by O'Reilly Auto Parts

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the PowerStrokeNation : Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome